CVE-2023-37544 Apache Pulsar WebSocket Proxy: Improper Authentication for WebSocket Proxy Endpoint Allows DoS
An attacker can bypass authentication on the WebSocket Proxy endpoint, leading to denial of service and excessive data transfer.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37544?
CVE-2023-37544 is a high-severity authentication bypass vulnerability in Apache Pulsar WebSocket Proxy, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication.
This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0.
The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature.
2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.
Weakness: CWE-287
Which versions are affected by CVE-2023-37544?
6 open source packages ship an affected version, including org.apache.pulsar:pulsar-websocket. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.pulsar:pulsar-websocket Maven | All versions | 2.10.5 |
org.apache.pulsar:pulsar-websocket Maven | All versions | 2.10.5 |
org.apache.pulsar:pulsar-websocket Maven | From 2.11.0 | 2.11.2 |
org.apache.pulsar:pulsar-websocket Maven | From 2.11.0 | 2.11.2 |
org.apache.pulsar:pulsar-websocket Maven | From 3.0.0 | 3.0.1 |
org.apache.pulsar:pulsar-websocket Maven | From 3.0.0 | 3.0.1 |
Products include Apache Pulsar.
How do I fix CVE-2023-37544?
Upgrade org.apache.pulsar:pulsar-websocket to a fixed version for your release line: 2.10.5, 2.11.2 or 3.0.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2023-37544 being exploited?
There is no known exploitation of CVE-2023-37544 in the wild and no public exploit code.
Other vulnerabilities in Apache Pulsar WebSocket Proxy
- CVE-2021-22160 Authentication with JWT allows use of “none”-algorithm
- CVE-2023-30429 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- CVE-2024-27135 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- CVE-2024-27894 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
- CVE-2024-27317 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Sources
Also known as GHSA-83q5-whqp-r8jr.