# CVE-2023-37544: Apache Pulsar WebSocket Proxy: Improper Authentication for WebSocket Proxy Endpoint Allows DoS

> An attacker can bypass authentication on the WebSocket Proxy endpoint, leading to denial of service and excessive data transfer.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-83q5-whqp-r8jr

## What is CVE-2023-37544?

CVE-2023-37544 is a high-severity authentication bypass vulnerability in Apache Pulsar WebSocket Proxy, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication.

This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0.

The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature.

2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5.
2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2.
3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1.
3.1 Pulsar WebSocket Proxy users are unaffected.
Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2023-37544?

6 open source packages ship an affected version, including org.apache.pulsar:pulsar-websocket. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.pulsar:pulsar-websocket` | Maven | All versions | 2.10.5 |
| `org.apache.pulsar:pulsar-websocket` | Maven | All versions | 2.10.5 |
| `org.apache.pulsar:pulsar-websocket` | Maven | From 2.11.0 | 2.11.2 |
| `org.apache.pulsar:pulsar-websocket` | Maven | From 2.11.0 | 2.11.2 |
| `org.apache.pulsar:pulsar-websocket` | Maven | From 3.0.0 | 3.0.1 |
| `org.apache.pulsar:pulsar-websocket` | Maven | From 3.0.0 | 3.0.1 |

Products: Apache Pulsar.

## How do I fix CVE-2023-37544?

Upgrade org.apache.pulsar:pulsar-websocket to a fixed version for your release line: 2.10.5, 2.11.2 or 3.0.1.

## Is CVE-2023-37544 being exploited?

There is no known exploitation of CVE-2023-37544 in the wild and no public exploit code.

## Other vulnerabilities in Apache Pulsar WebSocket Proxy

- [CVE-2021-22160](https://insights.sbomify.com/CVE-2021-22160/): Authentication with JWT allows use of “none”-algorithm (critical 9.8)
- [CVE-2023-30429](https://insights.sbomify.com/CVE-2023-30429/): Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy (critical 9.6)
- [CVE-2024-27135](https://insights.sbomify.com/CVE-2024-27135/): Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution (high 8.5)
- [CVE-2024-27894](https://insights.sbomify.com/CVE-2024-27894/): Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying (high 8.5)
- [CVE-2024-27317](https://insights.sbomify.com/CVE-2024-27317/): Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37544 and fix it if it is affected.

What it is: CVE-2023-37544 is a high-severity authentication bypass vulnerability in Apache Pulsar WebSocket Proxy, published on 20 Dec 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37544 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.pulsar:pulsar-websocket (Maven): affected all versions; fixed in 2.10.5
- org.apache.pulsar:pulsar-websocket (Maven): affected all versions; fixed in 2.10.5
- org.apache.pulsar:pulsar-websocket (Maven): affected from 2.11.0; fixed in 2.11.2
- org.apache.pulsar:pulsar-websocket (Maven): affected from 2.11.0; fixed in 2.11.2
- org.apache.pulsar:pulsar-websocket (Maven): affected from 3.0.0; fixed in 3.0.1
- org.apache.pulsar:pulsar-websocket (Maven): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37544/ (Markdown: https://insights.sbomify.com/CVE-2023-37544/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37544
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37544
- OSV: https://osv.dev/vulnerability/CVE-2023-37544

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37544/
Summaries are generated and may contain mistakes; the official description above is the record.
