CVE-2023-37579 Apache Pulsar Function Worker: Incorrect Authorization for Function Worker Can Leak Sink/Source Credentials
Authenticated users can retrieve source or sink configurations, potentially leaking embedded credentials, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37579?
CVE-2023-37579 is a high-severity missing authorization vulnerability in Apache Pulsar Function Worker, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar Function Worker.
This issue affects Apache Pulsar: before 2.10.4, and 2.11.0.
Any authenticated user can retrieve a source's configuration or a sink's configuration without authorization. Many sources and sinks contain credentials in the configuration, which could lead to leaked credentials. This vulnerability is mitigated by the fact that there is not a known way for an authenticated user to enumerate another tenant's sources or sinks, meaning the source or sink name would need to be guessed in order to exploit this vulnerability.
The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version.
2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.
Weakness: CWE-863
Which versions are affected by CVE-2023-37579?
4 open source packages ship an affected version, including org.apache.pulsar:pulsar-functions-worker. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.pulsar:pulsar-functions-worker Maven | All versions | 2.10.4 |
org.apache.pulsar:pulsar-functions-worker Maven | All versions | 2.10.4 |
org.apache.pulsar:pulsar-functions-worker Maven | From 2.11.0 | 2.11.1 |
org.apache.pulsar:pulsar-functions-worker Maven | From 2.11.0 | 2.11.1 |
Products include Apache Pulsar.
How do I fix CVE-2023-37579?
Upgrade org.apache.pulsar:pulsar-functions-worker to a fixed version for your release line: 2.10.4 or 2.11.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-37579 being exploited?
There is no known exploitation of CVE-2023-37579 in the wild and no public exploit code.
Other vulnerabilities in Apache Pulsar Function Worker
- CVE-2021-22160 Authentication with JWT allows use of “none”-algorithm
- CVE-2023-30429 Apache Pulsar: Incorrect Authorization for Function Worker when using mTLS Authentication through Pulsar Proxy
- CVE-2024-27135 Apache Pulsar: Improper Input Validation in Pulsar Function Worker allows Remote Code Execution
- CVE-2024-27894 Apache Pulsar: Pulsar Functions Worker Allows Unauthorized File Access and Unauthorized HTTP/HTTPS Proxying
- CVE-2024-27317 Apache Pulsar: Pulsar Functions Worker's Archive Extraction Vulnerability Allows Unauthorized File Modification
Sources
Also known as GHSA-74mc-g2xv-pch2.