# CVE-2023-37611: Neos CMS Cross Site Scripting vulnerability

> Remote authenticated attackers can execute arbitrary code via crafted SVG files in Neos CMS media management.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Sep 2023
- **Updated:** 2 Aug 2024
- **Also known as:** BIT-neos-2023-37611, GHSA-6qjf-7g3j-qx25

## What is CVE-2023-37611?

CVE-2023-37611 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting (XSS) vulnerability in Neos CMS 8.3.3 allows a remote authenticated attacker to execute arbitrary code via a crafted SVG file to the neos/management/media component.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-37611?

11 open source packages ship an affected version, including neos/media-browser and neos. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neos/media-browser` | Packagist | All versions | 7.3.19 |
| `neos/media-browser` | Packagist | All versions | 7.3.19 |
| `neos/media-browser` | Packagist | From 8.0.0 | 8.0.16 |
| `neos/media-browser` | Packagist | From 8.0.0 | 8.0.16 |
| `neos/media-browser` | Packagist | From 8.1.0 | 8.1.11 |
| `neos/media-browser` | Packagist | From 8.1.0 | 8.1.11 |
| `neos/media-browser` | Packagist | From 8.2.0 | 8.2.11 |
| `neos/media-browser` | Packagist | From 8.2.0 | 8.2.11 |
| `neos/media-browser` | Packagist | From 8.3.0 | 8.3.9 |
| `neos/media-browser` | Packagist | From 8.3.0 | 8.3.9 |
| `neos` | Bitnami | From 8.3.3 to 8.3.3 | None |

Products: Neos Neos Cms.

## How do I fix CVE-2023-37611?

Upgrade neos/media-browser to a fixed version for your release line: 7.3.19, 8.0.16, 8.1.11 or 8.2.11.

## Is CVE-2023-37611 being exploited?

There is no known exploitation of CVE-2023-37611 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-30429](https://insights.sbomify.com/CVE-2022-30429/): Neos CMS vulnerable to XSS in various backend modules (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37611 and fix it if it is affected.

What it is: CVE-2023-37611 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Sep 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37611 in the wild and no public exploit code.

Affected packages and fixed versions:
- neos/media-browser (Packagist): affected all versions; fixed in 7.3.19
- neos/media-browser (Packagist): affected all versions; fixed in 7.3.19
- neos/media-browser (Packagist): affected from 8.0.0; fixed in 8.0.16
- neos/media-browser (Packagist): affected from 8.0.0; fixed in 8.0.16
- neos/media-browser (Packagist): affected from 8.1.0; fixed in 8.1.11
- neos/media-browser (Packagist): affected from 8.1.0; fixed in 8.1.11
- neos/media-browser (Packagist): affected from 8.2.0; fixed in 8.2.11
- neos/media-browser (Packagist): affected from 8.2.0; fixed in 8.2.11
- neos/media-browser (Packagist): affected from 8.3.0; fixed in 8.3.9
- neos/media-browser (Packagist): affected from 8.3.0; fixed in 8.3.9
- neos (Bitnami): affected from 8.3.3 up to 8.3.3; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37611/ (Markdown: https://insights.sbomify.com/CVE-2023-37611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37611
- OSV: https://osv.dev/vulnerability/CVE-2023-37611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37611/
Summaries are generated and may contain mistakes; the official description above is the record.
