{"answers":{"affected":"3 open source packages ship an affected version, including xalpha. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37659 exists.","fix":"Upgrade xalpha to 0.11.9 or later.","what":"CVE-2023-37659 is a critical code injection vulnerability in n/a, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37659 and fix it if it is affected.\n\nWhat it is: CVE-2023-37659 is a critical code injection vulnerability in n/a, published on 11 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37659 exists.\n\nAffected packages and fixed versions:\n- xalpha (PyPI): affected from 0.11.4; fixed in 0.11.9\n- xalpha (PyPI): affected from 0.11.4; fixed in 0.11.9\n- xalpha (PyPI): affected from 0.11.4; fixed in 0.11.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37659/ (Markdown: https://insights.sbomify.com/CVE-2023-37659/index.md)","id":"CVE-2023-37659","markdown":"https://insights.sbomify.com/CVE-2023-37659/index.md","name":"CVE-2023-37659","record":{"aliases":["GHSA-jx3q-5rgf-vrrr","PYSEC-2023-116"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python financial library","requires_auth":"none","summary":"Attackers can execute arbitrary code remotely via the xalpha Python library, requiring users to upgrade to a patched version.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"xalpha","vendor":"xalpha_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"xalpha v0.11.4 is vulnerable to Remote Command Execution (RCE).","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"xalpha vulnerable to Remote Code Execution","id":"CVE-2023-37659","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2023"},"n_packages":3,"n_references":1,"next":{"headline":"File upload in n/a","id":"CVE-2023-37677"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.9"],"introduced":["0.11.4"],"last_affected":[],"package":"xalpha","purl":null,"source":"GHSA-jx3q-5rgf-vrrr"},{"ecosystem":"PyPI","fixed":["0.11.9"],"introduced":["0.11.4"],"last_affected":[],"package":"xalpha","purl":"pkg:pypi/xalpha","source":"GHSA-jx3q-5rgf-vrrr"},{"ecosystem":"PyPI","fixed":["0.11.9"],"introduced":["0.11.4"],"last_affected":[],"package":"xalpha","purl":"pkg:pypi/xalpha","source":"PYSEC-2023-116"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2023-37658"},"products":["n/a"],"published":"2023-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-11-08","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code remotely via the xalpha Python library, requiring users to upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2023-37659/"}