{"answers":{"affected":"2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37897 exists.","fix":"Upgrade getgrav/grav to 1.7.42.2 or later.","what":"CVE-2023-37897 is a high-severity code injection vulnerability in Getgrav Grav, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37897 and fix it if it is affected.\n\nWhat it is: CVE-2023-37897 is a high-severity code injection vulnerability in Getgrav Grav, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37897 exists.\n\nAffected packages and fixed versions:\n- getgrav/grav (Packagist): affected all versions; fixed in 1.7.42.2\n- getgrav/grav (Packagist): affected all versions; fixed in 1.7.42.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37897/ (Markdown: https://insights.sbomify.com/CVE-2023-37897/index.md)","id":"CVE-2023-37897","markdown":"https://insights.sbomify.com/CVE-2023-37897/index.md","name":"CVE-2023-37897","record":{"aliases":["GHSA-9436-3gmp-4f53"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Grav CMS","requires_auth":"high_privilege","summary":"An attacker with admin or page-editing privileges can execute arbitrary code via a Server-Side Template Injection bypass in Grav CMS.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"grav","vendor":"getgrav"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-393","name":"Return of Wrong Status Code"}],"description":"Grav is a file-based Web-platform built in PHP. Grav is subject to a server side template injection (SSTI) vulnerability. The fix for another SSTI vulnerability using `|map`, `|filter` and `|reduce` twigs implemented in the commit `71bbed1` introduces bypass of the denylist due to incorrect return value from `isDangerousFunction()`, which allows to execute the payload prepending double backslash (`\\\\`). The `isDangerousFunction()` check in version 1.7.42 and onwards retuns `false` value instead of `true` when the `\\` symbol is found in the `$name`. This vulnerability can be exploited if the attacker has access to: 1. an Administrator account, or 2. a non-administrator, user account that has Admin panel access and Create/Update page permissions. A fix for this vulnerability has been introduced in commit `b4c6210` and is included in release version `1.7.42.2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Server-side Template Injection (SSTI) in grav","id":"CVE-2023-37897","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"getgrav:grav","products":["getgrav:grav"],"type":"code_injection","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"Safe mode Cross-site Scripting (XSS) vulnerability in Joplin","id":"CVE-2023-37898"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.42.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":null,"source":"GHSA-9436-3gmp-4f53"},{"ecosystem":"Packagist","fixed":["1.7.42.2"],"introduced":["0"],"last_affected":[],"package":"getgrav/grav","purl":"pkg:composer/getgrav/grav","source":"GHSA-9436-3gmp-4f53"}],"prev":{"headline":"Nuclei Path Traversal vulnerability","id":"CVE-2023-37896"},"products":["grav"],"published":"2023-07-18","related":[{"cvss_score":10,"headline":"Grav Server Side Template Injection vulnerability","id":"CVE-2023-34251","kev_date_added":null,"published":"2023-06-14"},{"cvss_score":9.8,"headline":"Cross-site scripting in n/a","id":"CVE-2025-46199","kev_date_added":null,"published":"2025-07-25"},{"cvss_score":9.3,"headline":"GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2)","id":"CVE-2021-47812","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":9.1,"headline":"Grav may be vulnerable to SSRF attack via Twig Templates","id":"CVE-2025-66844","kev_date_added":null,"published":"2025-12-15"},{"cvss_score":9.1,"headline":"Code Injection in getgrav/grav","id":"CVE-2022-2073","kev_date_added":null,"published":"2022-06-29"},{"cvss_score":8.9,"headline":"Grav: Stored XSS via Tag Injection","id":"CVE-2026-42611","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":8.8,"headline":"Grav: Unauthenticated Path Traversal \u0026 Arbitrary File Write in FormFlash component.","id":"CVE-2026-42608","kev_date_added":null,"published":"2026-05-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-18","vendors":["getgrav"]},"summary":"An attacker with admin or page-editing privileges can execute arbitrary code via a Server-Side Template Injection bypass in Grav CMS.","url":"https://insights.sbomify.com/CVE-2023-37897/"}