# CVE-2023-37897: Server-side Template Injection (SSTI) in grav

> An attacker with admin or page-editing privileges can execute arbitrary code via a Server-Side Template Injection bypass in Grav CMS.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2023
- **Updated:** 18 Oct 2024
- **Also known as:** GHSA-9436-3gmp-4f53

## What is CVE-2023-37897?

CVE-2023-37897 is a high-severity code injection vulnerability in Getgrav Grav, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grav is a file-based Web-platform built in PHP. Grav is subject to a server side template injection (SSTI) vulnerability. The fix for another SSTI vulnerability using `|map`, `|filter` and `|reduce` twigs implemented in the commit `71bbed1` introduces bypass of the denylist due to incorrect return value from `isDangerousFunction()`, which allows to execute the payload prepending double backslash (`\\`). The `isDangerousFunction()` check in version 1.7.42 and onwards retuns `false` value instead of `true` when the `\` symbol is found in the `$name`. This vulnerability can be exploited if the attacker has access to: 1. an Administrator account, or 2. a non-administrator, user account that has Admin panel access and Create/Update page permissions. A fix for this vulnerability has been introduced in commit `b4c6210` and is included in release version `1.7.42.2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-393 (Return of Wrong Status Code)

## Which versions are affected by CVE-2023-37897?

2 open source packages ship an affected version, including getgrav/grav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.42.2 |
| `getgrav/grav` | Packagist | All versions | 1.7.42.2 |

Products: Getgrav Grav.

## How do I fix CVE-2023-37897?

Upgrade getgrav/grav to 1.7.42.2 or later.

## Is CVE-2023-37897 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37897 exists.

## Other vulnerabilities in Getgrav Grav

- [CVE-2023-34251](https://insights.sbomify.com/CVE-2023-34251/): Grav Server Side Template Injection vulnerability (critical 10.0)
- [CVE-2025-46199](https://insights.sbomify.com/CVE-2025-46199/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2021-47812](https://insights.sbomify.com/CVE-2021-47812/): GravCMS 1.10.7 - Arbitrary YAML Write/Update (Unauthenticated) (2) (critical 9.3)
- [CVE-2025-66844](https://insights.sbomify.com/CVE-2025-66844/): Grav may be vulnerable to SSRF attack via Twig Templates (critical 9.1)
- [CVE-2022-2073](https://insights.sbomify.com/CVE-2022-2073/): Code Injection in getgrav/grav (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37897 and fix it if it is affected.

What it is: CVE-2023-37897 is a high-severity code injection vulnerability in Getgrav Grav, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37897 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.42.2
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.42.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37897/ (Markdown: https://insights.sbomify.com/CVE-2023-37897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37897
- OSV: https://osv.dev/vulnerability/CVE-2023-37897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37897/
Summaries are generated and may contain mistakes; the official description above is the record.
