CVE-2023-37900 Crossplane vulnerable to denial of service from large image
A high-privileged user can cause a denial of service by creating a package referencing an arbitrarily large image, exhausting memory.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-37900?
CVE-2023-37900 is a low-severity denial of service vulnerability in crossplane, published on 27 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, a high-privileged user could create a Package referencing an arbitrarily large image containing that Crossplane would then parse, possibly resulting in exhausting all the available memory and therefore in the container being OOMKilled. The impact is limited due to the high privileges required to be able to create the Package and the eventually consistency nature of controller. This issue is fixed in versions 1.11.5, 1.12.3, and 1.13.0.
Which versions are affected by CVE-2023-37900?
6 open source packages ship an affected version, including github.com/crossplane/crossplane and crossplane. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/crossplane/crossplane Go | All versions | 1.11.5, 1.12.3 |
github.com/crossplane/crossplane Go | All versions | 1.11.5 |
github.com/crossplane/crossplane Go | All versions | 1.11.5 |
github.com/crossplane/crossplane Go | From 1.12.0 | 1.12.3 |
github.com/crossplane/crossplane Go | From 1.12.0 | 1.12.3 |
crossplane Bitnami | All versions | 1.11.5, 1.12.3 |
Products include Cncf Crossplane.
How do I fix CVE-2023-37900?
Upgrade github.com/crossplane/crossplane to a fixed version for your release line: 1.11.5 or 1.12.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2023-37900 being exploited?
There is no known exploitation of CVE-2023-37900 in the wild and no public exploit code.
Other vulnerabilities in crossplane
Sources
Also known as BIT-crossplane-2023-37900, GHSA-68p4-95xf-7gx8, GO-2023-1979.