# CVE-2023-37900: Crossplane vulnerable to denial of service from large image

> A high-privileged user can cause a denial of service by creating a package referencing an arbitrarily large image, exhausting memory.

- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2023
- **Updated:** 15 Oct 2024
- **Also known as:** BIT-crossplane-2023-37900, GHSA-68p4-95xf-7gx8, GO-2023-1979

## What is CVE-2023-37900?

CVE-2023-37900 is a low-severity denial of service vulnerability in crossplane, published on 27 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Crossplane is a framework for building cloud native control planes without needing to write code. In versions prior to 1.11.5, 1.12.3, and 1.13.0, a high-privileged user could create a Package referencing an arbitrarily large image containing that Crossplane would then parse, possibly resulting in exhausting all the available memory and therefore in the container being OOMKilled. The impact is limited due to the high privileges required to be able to create the Package and the eventually consistency nature of controller. This issue is fixed in versions 1.11.5, 1.12.3, and 1.13.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2023-37900?

6 open source packages ship an affected version, including github.com/crossplane/crossplane and crossplane. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/crossplane/crossplane` | Go | All versions | 1.11.5, 1.12.3 |
| `github.com/crossplane/crossplane` | Go | All versions | 1.11.5 |
| `github.com/crossplane/crossplane` | Go | All versions | 1.11.5 |
| `github.com/crossplane/crossplane` | Go | From 1.12.0 | 1.12.3 |
| `github.com/crossplane/crossplane` | Go | From 1.12.0 | 1.12.3 |
| `crossplane` | Bitnami | All versions | 1.11.5, 1.12.3 |

Products: Cncf Crossplane.

## How do I fix CVE-2023-37900?

Upgrade github.com/crossplane/crossplane to a fixed version for your release line: 1.11.5 or 1.12.3.

## Is CVE-2023-37900 being exploited?

There is no known exploitation of CVE-2023-37900 in the wild and no public exploit code.

## Other vulnerabilities in crossplane

- [CVE-2023-38495](https://insights.sbomify.com/CVE-2023-38495/): Crossplane vulnerable to possible image tampering from missing image validation for Packages (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37900 and fix it if it is affected.

What it is: CVE-2023-37900 is a low-severity denial of service vulnerability in crossplane, published on 27 Jul 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-37900 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/crossplane/crossplane (Go): affected all versions; fixed in 1.11.5, 1.12.3
- github.com/crossplane/crossplane (Go): affected all versions; fixed in 1.11.5
- github.com/crossplane/crossplane (Go): affected all versions; fixed in 1.11.5
- github.com/crossplane/crossplane (Go): affected from 1.12.0; fixed in 1.12.3
- github.com/crossplane/crossplane (Go): affected from 1.12.0; fixed in 1.12.3
- crossplane (Bitnami): affected all versions; fixed in 1.11.5, 1.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37900/ (Markdown: https://insights.sbomify.com/CVE-2023-37900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37900
- OSV: https://osv.dev/vulnerability/CVE-2023-37900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37900/
Summaries are generated and may contain mistakes; the official description above is the record.
