{"answers":{"affected":"3 open source packages ship an affected version, including indico. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-37901 in the wild and no public exploit code.","fix":"Upgrade indico to 3.2.6 or later.","what":"CVE-2023-37901 is a medium-severity cross-site scripting vulnerability in indico, published on 21 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-37901 and fix it if it is affected.\n\nWhat it is: CVE-2023-37901 is a medium-severity cross-site scripting vulnerability in indico, published on 21 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-37901 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- indico (PyPI): affected all versions; fixed in 3.2.6\n- indico (PyPI): affected all versions; fixed in 3.2.6\n- indico (PyPI): affected all versions; fixed in 3.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37901/ (Markdown: https://insights.sbomify.com/CVE-2023-37901/index.md)","id":"CVE-2023-37901","markdown":"https://insights.sbomify.com/CVE-2023-37901/index.md","name":"CVE-2023-37901","record":{"aliases":["GHSA-fmqq-25x9-c6hm","PYSEC-2023-129"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Indico event management","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts into confirmation prompts, potentially compromising user accounts when organizers delete suspicious content.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"indico","vendor":"cern"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Indico is an open source a general-purpose, web based event management tool. There is a Cross-Site-Scripting vulnerability in confirmation prompts commonly used when deleting content from Indico. Exploitation requires someone with at least submission privileges (such as a speaker) and then someone else to attempt to delete this content. Considering that event organizers may want to delete suspicious-looking content when spotting it, there is a non-negligible risk of such an attack to succeed. The risk of this could be further increased when combined with some some social engineering pointing the victim towards this content. Users need to update to Indico 3.2.6 as soon as possible. See the docs for instructions on how to update. Users who cannot upgrade should only let trustworthy users manage categories, create events or upload materials (\"submission\" privileges on a contribution/event). This should already be the case in a properly-configured setup when it comes to category/event management. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site-Scripting via confirmation prompts","id":"CVE-2023-37901","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":3,"n_references":4,"next":{"headline":"Vyper's ecrecover can return undefined data if signature does not verify","id":"CVE-2023-37902"},"packages":[{"ecosystem":"PyPI","fixed":["3.2.6"],"introduced":["0"],"last_affected":[],"package":"indico","purl":null,"source":"GHSA-fmqq-25x9-c6hm"},{"ecosystem":"PyPI","fixed":["3.2.6"],"introduced":["0"],"last_affected":[],"package":"indico","purl":"pkg:pypi/indico","source":"GHSA-fmqq-25x9-c6hm"},{"ecosystem":"PyPI","fixed":["3.2.6"],"introduced":["0"],"last_affected":[],"package":"indico","purl":"pkg:pypi/indico","source":"PYSEC-2023-129"}],"prev":{"headline":"Crossplane vulnerable to denial of service from large image","id":"CVE-2023-37900"},"products":["indico"],"published":"2023-07-21","related":[{"cvss_score":7.7,"headline":"Indico discloses local files resulting in Remote Code Execution through LaTeX injection","id":"CVE-2026-33046","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Indico Tampering with links (e.g. password reset) in sent emails","id":"CVE-2021-30185","kev_date_added":null,"published":"2021-04-07"},{"cvss_score":6.9,"headline":"Indico has Server-Side Request Forgery (SSRF) in multiple places","id":"CVE-2026-25738","kev_date_added":null,"published":"2026-02-19"},{"cvss_score":6.5,"headline":"Indico missing access check in event series management API","id":"CVE-2026-28352","kev_date_added":null,"published":"2026-02-27"},{"cvss_score":5.4,"headline":"Indico affected by Cross-Site-Scripting via material uploads","id":"CVE-2026-25739","kev_date_added":null,"published":"2026-02-19"},{"cvss_score":5.3,"headline":"Indico vulnerable to user enumeration via API endpoint","id":"CVE-2025-53640","kev_date_added":null,"published":"2025-07-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-10","vendors":["indico"]},"summary":"Attackers can inject malicious scripts into confirmation prompts, potentially compromising user accounts when organizers delete suspicious content.","url":"https://insights.sbomify.com/CVE-2023-37901/"}