# CVE-2023-37902: Vyper's ecrecover can return undefined data if signature does not verify

> Vyper compiler flaw allows invalid signatures to pass verification if memory is crafted, bypassing authentication checks in smart contracts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 3 Oct 2024
- **Also known as:** GHSA-f5x6-7qgp-jhf3, PYSEC-2023-133

## What is CVE-2023-37902?

CVE-2023-37902 is a medium-severity vulnerability in vyperlang vyper, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a Pythonic programming language that targets the Ethereum Virtual Machine (EVM). Prior to version 0.3.10, the ecrecover precompile does not fill the output buffer if the signature does not verify. However, the ecrecover builtin will still return whatever is at memory location 0. This means that the if the compiler has been convinced to write to the 0 memory location with specially crafted data (generally, this can happen with a hashmap access or immutable read) just before the ecrecover, a signature check might pass on an invalid signature. Version 0.3.10 contains a patch for this issue.

Weakness: CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2023-37902?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.10 |
| `vyper` | PyPI | All versions | 0.3.10 |
| `vyper` | PyPI | All versions | 0.3.9 |

Products: Vyperlang Vyper.

## How do I fix CVE-2023-37902?

Upgrade vyper to a fixed version for your release line: 0.3.10 or 0.3.9.

## Is CVE-2023-37902 being exploited?

There is no known exploitation of CVE-2023-37902 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37902 and fix it if it is affected.

What it is: CVE-2023-37902 is a medium-severity vulnerability in vyperlang vyper, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37902 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.10
- vyper (PyPI): affected all versions; fixed in 0.3.10
- vyper (PyPI): affected all versions; fixed in 0.3.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37902/ (Markdown: https://insights.sbomify.com/CVE-2023-37902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37902
- OSV: https://osv.dev/vulnerability/CVE-2023-37902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37902/
Summaries are generated and may contain mistakes; the official description above is the record.
