CVE-2023-37904 Discourse Race Condition in Accept Invite

Low 2.6 Published Updated

Attackers can bypass invite limits to create unauthorized accounts in Discourse forums, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2023-37904?

CVE-2023-37904 is a low-severity vulnerability in Discourse Discourse, published on 28 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, more users than permitted could be created from invite links. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. As a workaround, use restrict to email address invites.

Weakness: CWE-362

Which versions are affected by CVE-2023-37904?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.6

Products include Discourse Discourse.

How do I fix CVE-2023-37904?

Upgrade discourse to 3.0.6 or later.

Is CVE-2023-37904 being exploited?

There is no known exploitation of CVE-2023-37904 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-37904, GHSA-6wj5-4ph2-c7qg.

Is CVE-2023-37904 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free