{"answers":{"affected":"2 open source packages ship an affected version, including ckeditor-wordcount-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-37905 in the wild and no public exploit code.","fix":"Upgrade ckeditor-wordcount-plugin to 1.17.12 or later.","what":"CVE-2023-37905 is a medium-severity cross-site scripting vulnerability in typo3 CKEditor-WordCount-Plugin, published on 21 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-37905 and fix it if it is affected.\n\nWhat it is: CVE-2023-37905 is a medium-severity cross-site scripting vulnerability in typo3 CKEditor-WordCount-Plugin, published on 21 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-37905 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ckeditor-wordcount-plugin (npm): affected all versions; fixed in 1.17.12\n- ckeditor-wordcount-plugin (npm): affected all versions; fixed in 1.17.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37905/ (Markdown: https://insights.sbomify.com/CVE-2023-37905/index.md)","id":"CVE-2023-37905","markdown":"https://insights.sbomify.com/CVE-2023-37905/index.md","name":"CVE-2023-37905","record":{"aliases":["GHSA-q9w4-w667-qqj4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"CKEditor WordCount Plugin","requires_auth":"none","summary":"An attacker can execute arbitrary scripts via cross-site scripting in the source mode of the CKEditor WordCount plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ckeditor-wordcount-plugin","vendor":"ckeditor-wordcount-plugin_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ckeditor-wordcount-plugin is an open source WordCount Plugin for CKEditor. It has been discovered that the `ckeditor-wordcount-plugin` plugin for CKEditor4 is susceptible to cross-site scripting when switching to the source code mode. This issue has been addressed in version 1.17.12 of the `ckeditor-wordcount-plugin` plugin and users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting (XSS) in Source Mode of Editor in ckeditor-wordcount-plugin","id":"CVE-2023-37905","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2023"},"n_packages":2,"n_references":5,"next":{"headline":"Discourse vulnerable to DoS via post edit reason","id":"CVE-2023-37906"},"packages":[{"ecosystem":"npm","fixed":["1.17.12"],"introduced":["0"],"last_affected":[],"package":"ckeditor-wordcount-plugin","purl":null,"source":"GHSA-q9w4-w667-qqj4"},{"ecosystem":"npm","fixed":["1.17.12"],"introduced":["0"],"last_affected":[],"package":"ckeditor-wordcount-plugin","purl":"pkg:npm/ckeditor-wordcount-plugin","source":"GHSA-q9w4-w667-qqj4"}],"prev":{"headline":"Discourse Race Condition in Accept Invite","id":"CVE-2023-37904"},"products":["CKEditor-WordCount-Plugin","cms-rte-ckeditor"],"published":"2023-07-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-21","vendors":["typo3","w8tcha"]},"summary":"An attacker can execute arbitrary scripts via cross-site scripting in the source mode of the CKEditor WordCount plugin.","url":"https://insights.sbomify.com/CVE-2023-37905/"}