CVE-2023-37906 Discourse vulnerable to DoS via post edit reason

Medium 4.3 Published Updated

A malicious user can cause a denial of service in Discourse by submitting a carefully crafted edit reason for a post.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-37906?

CVE-2023-37906 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 28 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can edit a post in a topic and cause a DoS with a carefully crafted edit reason. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability.

Weakness: CWE-770

Which versions are affected by CVE-2023-37906?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.6

Products include Discourse Discourse.

How do I fix CVE-2023-37906?

Upgrade discourse to 3.0.6 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-37906 being exploited?

There is no known exploitation of CVE-2023-37906 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-37906, GHSA-pjv6-47x6-mx7c.

Is CVE-2023-37906 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free