# CVE-2023-37908: org.xwiki.rendering:xwiki-rendering-xml Improper Neutralization of Invalid Characters in Identifiers in Web Pages vulnerability

> Attackers can inject malicious JavaScript via invalid attribute names in XWiki rendering, leading to session hijacking or server-side code execution for privileged users.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-663w-2xp3-5739

## What is CVE-2023-37908?

CVE-2023-37908 is a critical cross-site scripting vulnerability in xwiki-rendering, published on 25 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki Rendering is a generic Rendering system that converts textual input in a given syntax into another syntax. The cleaning of attributes during XHTML rendering, introduced in version 14.6-rc-1, allowed the injection of arbitrary HTML code and thus cross-site scripting via invalid attribute names. This can be exploited, e.g., via the link syntax in any content that supports XWiki syntax like comments in XWiki. When a user moves the mouse over a malicious link, the malicious JavaScript code is executed in the context of the user session. When this user is a privileged user who has programming rights, this allows server-side code execution with programming rights, impacting the confidentiality, integrity and availability of the XWiki instance. While this attribute was correctly recognized as not allowed, the attribute was still printed with a prefix `data-xwiki-translated-attribute-` without further cleaning or validation. This problem has been patched in XWiki 14.10.4 and 15.0 RC1 by removing characters not allowed in data attributes and then validating the cleaned attribute again. There are no known workarounds apart from upgrading to a version including the fix.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-83 (Improper Neutralization of Script in Attributes in a Web Page)

## Which versions are affected by CVE-2023-37908?

2 open source packages ship an affected version, including org.xwiki.rendering:xwiki-rendering-xml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.rendering:xwiki-rendering-xml` | Maven | From 14.6-rc-1 | 14.10.4 |
| `org.xwiki.rendering:xwiki-rendering-xml` | Maven | From 14.6-rc-1 | 14.10.4 |

Products: Xwiki Xwiki-Rendering.

## How do I fix CVE-2023-37908?

Upgrade org.xwiki.rendering:xwiki-rendering-xml to 14.10.4 or later.

## Is CVE-2023-37908 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37908 exists.

Public exploit code:

- https://github.com/shoucheng3/xwiki__xwiki-rendering_CVE-2023-37908_14-10-3 (github_poc): https://github.com/shoucheng3/xwiki__xwiki-rendering_CVE-2023-37908_14-10-3

## Other vulnerabilities in xwiki-rendering

- [CVE-2023-37912](https://insights.sbomify.com/CVE-2023-37912/): XWiki Rendering's footnote macro vulnerable to privilege escalation via the footnote macro (critical 10.0)
- [CVE-2025-66474](https://insights.sbomify.com/CVE-2025-66474/): XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37908 and fix it if it is affected.

What it is: CVE-2023-37908 is a critical cross-site scripting vulnerability in xwiki-rendering, published on 25 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37908 exists.

Affected packages and fixed versions:
- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected from 14.6-rc-1; fixed in 14.10.4
- org.xwiki.rendering:xwiki-rendering-xml (Maven): affected from 14.6-rc-1; fixed in 14.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37908/ (Markdown: https://insights.sbomify.com/CVE-2023-37908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37908
- OSV: https://osv.dev/vulnerability/CVE-2023-37908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37908/
Summaries are generated and may contain mistakes; the official description above is the record.
