CVE-2023-37909 Privilege escalation (PR)/remote code execution from account through Menu.UIExtensionSheet
Authenticated users can execute arbitrary scripts via profile editing, leading to remote code execution and full wiki access.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37909?
CVE-2023-37909 is a critical code injection vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 5.1-rc-1 and prior to versions 14.10.8 and 15.3-rc-1, any user who can edit their own user profile can execute arbitrary script macros including Groovy and Python macros that allow remote code execution including unrestricted read and write access to all wiki contents. This has been patched in XWiki 14.10.8 and 15.3-rc-1 by adding proper escaping. As a workaround, the patch can be manually applied to the document `Menu.UIExtensionSheet`; only three lines need to be changed.
Which versions are affected by CVE-2023-37909?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-menu-ui and org.xwiki.platform:xwiki-platform-menu. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-menu-ui Maven | From 15.0-rc-1 | 15.3-rc-1 |
org.xwiki.platform:xwiki-platform-menu-ui Maven | From 15.0-rc-1 | 15.3-rc-1 |
org.xwiki.platform:xwiki-platform-menu-ui Maven | From 5.1-rc-1 | 14.10.8 |
org.xwiki.platform:xwiki-platform-menu-ui Maven | From 5.1-rc-1 | 14.10.8 |
org.xwiki.platform:xwiki-platform-menu Maven | From 5.1-rc-1 | 14.10.8 |
org.xwiki.platform:xwiki-platform-menu Maven | From 5.1-rc-1 | 14.10.8 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-37909?
Upgrade org.xwiki.platform:xwiki-platform-menu-ui to a fixed version for your release line: 15.3-rc-1 or 14.10.8.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-37909 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37909 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-v2rr-xw95-wcjx.