CVE-2023-37910 org.xwiki.platform:xwiki-platform-attachment-api vulnerable to Missing Authorization on Attachment Move
An attacker with edit access to any document can move attachments from other documents, gaining unauthorized access and deleting them from the source.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37910?
CVE-2023-37910 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting with the introduction of attachment move support in version 14.0-rc-1 and prior to versions 14.4.8, 14.10.4, and 15.0-rc-1, an attacker with edit access on any document (can be the user profile which is editable by default) can move any attachment of any other document to this attacker-controlled document. This allows the attacker to access and possibly publish any attachment of which the name is known, regardless if the attacker has view or edit rights on the source document of this attachment. Further, the attachment is deleted from the source document. This vulnerability has been patched in XWiki 14.4.8, 14.10.4, and 15.0 RC1. There is no workaround apart from upgrading to a fixed version.
Weakness: CWE-862
Which versions are affected by CVE-2023-37910?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-attachment-api. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-attachment-api Maven | From 14.0-rc-1 | 14.4.8 |
org.xwiki.platform:xwiki-platform-attachment-api Maven | From 14.0-rc-1 | 14.4.8 |
org.xwiki.platform:xwiki-platform-attachment-api Maven | From 14.5 | 14.10.4 |
org.xwiki.platform:xwiki-platform-attachment-api Maven | From 14.5 | 14.10.4 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-37910?
Upgrade org.xwiki.platform:xwiki-platform-attachment-api to a fixed version for your release line: 14.4.8 or 14.10.4.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2023-37910 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37910 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-rwwx-6572-mp29.