# CVE-2023-37910: org.xwiki.platform:xwiki-platform-attachment-api vulnerable to Missing Authorization on Attachment Move

> An attacker with edit access to any document can move attachments from other documents, gaining unauthorized access and deleting them from the source.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rwwx-6572-mp29

## What is CVE-2023-37910?

CVE-2023-37910 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting with the introduction of attachment move support in version 14.0-rc-1 and prior to versions 14.4.8, 14.10.4, and 15.0-rc-1, an attacker with edit access on any document (can be the user profile which is editable by default) can move any attachment of any other document to this attacker-controlled document. This allows the attacker to access and possibly publish any attachment of which the name is known, regardless if the attacker has view or edit rights on the source document of this attachment. Further, the attachment is deleted from the source document. This vulnerability has been patched in XWiki 14.4.8, 14.10.4, and 15.0 RC1. There is no workaround apart from upgrading to a fixed version.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-37910?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-attachment-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-attachment-api` | Maven | From 14.0-rc-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-attachment-api` | Maven | From 14.0-rc-1 | 14.4.8 |
| `org.xwiki.platform:xwiki-platform-attachment-api` | Maven | From 14.5 | 14.10.4 |
| `org.xwiki.platform:xwiki-platform-attachment-api` | Maven | From 14.5 | 14.10.4 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-37910?

Upgrade org.xwiki.platform:xwiki-platform-attachment-api to a fixed version for your release line: 14.4.8 or 14.10.4.

## Is CVE-2023-37910 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37910 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37910 and fix it if it is affected.

What it is: CVE-2023-37910 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37910 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-attachment-api (Maven): affected from 14.0-rc-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-attachment-api (Maven): affected from 14.0-rc-1; fixed in 14.4.8
- org.xwiki.platform:xwiki-platform-attachment-api (Maven): affected from 14.5; fixed in 14.10.4
- org.xwiki.platform:xwiki-platform-attachment-api (Maven): affected from 14.5; fixed in 14.10.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37910/ (Markdown: https://insights.sbomify.com/CVE-2023-37910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37910
- OSV: https://osv.dev/vulnerability/CVE-2023-37910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37910/
Summaries are generated and may contain mistakes; the official description above is the record.
