CVE-2023-37911 org.xwiki.platform:xwiki-platform-oldcore may leak data through deleted and re-created documents
Attackers with view rights on re-created documents can access contents of previously deleted documents via diff or REST API, leaking sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37911?
CVE-2023-37911 is a medium-severity vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 9.4-rc-1 and prior to versions 14.10.8 and 15.3-rc-1, when a document has been deleted and re-created, it is possible for users with view right on the re-created document but not on the deleted document to view the contents of the deleted document. Such a situation might arise when rights were added to the deleted document. This can be exploited through the diff feature and, partially, through the REST API by using versions such as `deleted:1` (where the number counts the deletions in the wiki and is thus guessable). Given sufficient rights, the attacker can also re-create the deleted document, thus extending the scope to any deleted document as long as the attacker has edit right in the location of the deleted document. This vulnerability has been patched in XWiki 14.10.8 and 15.3 RC1 by properly checking rights when deleted revisions of a document are accessed. The only workaround is to regularly clean deleted documents to minimize the potential exposure. Extra care should be taken when deleting sensitive documents that are protected individually (and not, e.g., by being placed in a protected space) or deleting a protected space as a whole.
Weakness: CWE-668
Which versions are affected by CVE-2023-37911?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.3-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 15.0-rc-1 | 15.3-rc-1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 9.4-rc-1 | 14.10.8 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 9.4-rc-1 | 14.10.8 |
Products include Xwiki Xwiki.
How do I fix CVE-2023-37911?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.3-rc-1 or 14.10.8.
Is CVE-2023-37911 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37911 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-gh64-qxh5-4m33.