# CVE-2023-37911: org.xwiki.platform:xwiki-platform-oldcore may leak data through deleted and re-created documents

> Attackers with view rights on re-created documents can access contents of previously deleted documents via diff or REST API, leaking sensitive data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-gh64-qxh5-4m33

## What is CVE-2023-37911?

CVE-2023-37911 is a medium-severity vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 9.4-rc-1 and prior to versions 14.10.8 and 15.3-rc-1, when a document has been deleted and re-created, it is possible for users with view right on the re-created document but not on the deleted document to view the contents of the deleted document. Such a situation might arise when rights were added to the deleted document. This can be exploited through the diff feature and, partially, through the REST API by using versions such as `deleted:1` (where the number counts the deletions in the wiki and is thus guessable). Given sufficient rights, the attacker can also re-create the deleted document, thus extending the scope to any deleted document as long as the attacker has edit right in the location of the deleted document. This vulnerability has been patched in XWiki 14.10.8 and 15.3 RC1 by properly checking rights when deleted revisions of a document are accessed. The only workaround is to regularly clean deleted documents to minimize the potential exposure. Extra care should be taken when deleting sensitive documents that are protected individually (and not, e.g., by being placed in a protected space) or deleting a protected space as a whole.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2023-37911?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 15.0-rc-1 | 15.3-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 9.4-rc-1 | 14.10.8 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 9.4-rc-1 | 14.10.8 |

Products: Xwiki Xwiki.

## How do I fix CVE-2023-37911?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 15.3-rc-1 or 14.10.8.

## Is CVE-2023-37911 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37911 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37911 and fix it if it is affected.

What it is: CVE-2023-37911 is a medium-severity vulnerability in Xwiki Xwiki, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37911 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.3-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 15.0-rc-1; fixed in 15.3-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 9.4-rc-1; fixed in 14.10.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 9.4-rc-1; fixed in 14.10.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37911/ (Markdown: https://insights.sbomify.com/CVE-2023-37911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37911
- OSV: https://osv.dev/vulnerability/CVE-2023-37911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37911/
Summaries are generated and may contain mistakes; the official description above is the record.
