# CVE-2023-37912: XWiki Rendering's footnote macro vulnerable to privilege escalation via the footnote macro

> Attackers can escalate privileges to programming rights and execute remote code via the footnote macro in XWiki.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2023
- **Updated:** 12 Sep 2024
- **Also known as:** GHSA-35j5-m29r-xfq5

## What is CVE-2023-37912?

CVE-2023-37912 is a critical vulnerability in xwiki-rendering, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Rendering is a generic Rendering system that converts textual input in a given syntax into another syntax. Prior to version 14.10.6 of `org.xwiki.platform:xwiki-core-rendering-macro-footnotes` and `org.xwiki.platform:xwiki-rendering-macro-footnotes` and prior to version 15.1-rc-1 of `org.xwiki.platform:xwiki-rendering-macro-footnotes`, the footnote macro executed its content in a potentially different context than the one in which it was defined. In particular in combination with the include macro, this allows privilege escalation from a simple user account in XWiki to programming rights and thus remote code execution, impacting the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability has been patched in XWiki 14.10.6 and 15.1-rc-1. There is no workaround apart from upgrading to a fixed version of the footnote macro.

Weakness: CWE-270 (Privilege Context Switching Error)

## Which versions are affected by CVE-2023-37912?

6 open source packages ship an affected version, including org.xwiki.rendering:xwiki-rendering-macro-footnotes and org.xwiki.platform:xwiki-core-rendering-macro-footnotes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.rendering:xwiki-rendering-macro-footnotes` | Maven | All versions | 14.10.6 |
| `org.xwiki.rendering:xwiki-rendering-macro-footnotes` | Maven | All versions | 14.10.6 |
| `org.xwiki.rendering:xwiki-rendering-macro-footnotes` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.rendering:xwiki-rendering-macro-footnotes` | Maven | From 15.0-rc-1 | 15.1-rc-1 |
| `org.xwiki.platform:xwiki-core-rendering-macro-footnotes` | Maven | All versions | 14.10.6 |
| `org.xwiki.platform:xwiki-core-rendering-macro-footnotes` | Maven | All versions | 14.10.6 |

Products: Xwiki Xwiki-Rendering.

## How do I fix CVE-2023-37912?

Upgrade org.xwiki.rendering:xwiki-rendering-macro-footnotes to a fixed version for your release line: 14.10.6 or 15.1-rc-1.

## Is CVE-2023-37912 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37912 exists.

## Other vulnerabilities in xwiki-rendering

- [CVE-2023-37908](https://insights.sbomify.com/CVE-2023-37908/): org.xwiki.rendering:xwiki-rendering-xml Improper Neutralization of Invalid Characters in Identifiers in Web Pages vulnerability (critical 9.1)
- [CVE-2025-66474](https://insights.sbomify.com/CVE-2025-66474/): XWiki vulnerable to remote code execution through insufficient protection against {{/html}} injection (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37912 and fix it if it is affected.

What it is: CVE-2023-37912 is a critical vulnerability in xwiki-rendering, published on 25 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37912 exists.

Affected packages and fixed versions:
- org.xwiki.rendering:xwiki-rendering-macro-footnotes (Maven): affected all versions; fixed in 14.10.6
- org.xwiki.rendering:xwiki-rendering-macro-footnotes (Maven): affected all versions; fixed in 14.10.6
- org.xwiki.rendering:xwiki-rendering-macro-footnotes (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.rendering:xwiki-rendering-macro-footnotes (Maven): affected from 15.0-rc-1; fixed in 15.1-rc-1
- org.xwiki.platform:xwiki-core-rendering-macro-footnotes (Maven): affected all versions; fixed in 14.10.6
- org.xwiki.platform:xwiki-core-rendering-macro-footnotes (Maven): affected all versions; fixed in 14.10.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37912/ (Markdown: https://insights.sbomify.com/CVE-2023-37912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37912
- OSV: https://osv.dev/vulnerability/CVE-2023-37912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37912/
Summaries are generated and may contain mistakes; the official description above is the record.
