# CVE-2023-37917: Privilege Escalation in kubepi

> A normal user can escalate to admin by modifying the isadmin parameter, allowing full control of the KubePi panel.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2023
- **Updated:** 10 Oct 2024
- **Also known as:** GHSA-757p-vx43-fp9r, GO-2023-1956

## What is CVE-2023-37917?

CVE-2023-37917 is a critical vulnerability in 1Panel-dev KubePi, published on 21 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

KubePi is an opensource kubernetes management panel. A normal user has permission to create/update users, they can become admin by editing the `isadmin` value in the request. As a result any user may take administrative control of KubePi. This issue has been addressed in version 1.6.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2023-37917?

3 open source packages ship an affected version, including github.com/KubeOperator/kubepi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/KubeOperator/kubepi` | Go | All versions | 1.6.5 |
| `github.com/KubeOperator/kubepi` | Go | All versions | 1.6.5 |
| `github.com/KubeOperator/kubepi` | Go | All versions | 1.6.5 |

Products: Fit2cloud Kubepi.

## How do I fix CVE-2023-37917?

Upgrade github.com/KubeOperator/kubepi to 1.6.5 or later.

## Is CVE-2023-37917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37917 exists.

## Other vulnerabilities in 1Panel-dev KubePi

- [CVE-2023-22463](https://insights.sbomify.com/CVE-2023-22463/): KubePi's Hardcoded Jwtsigkeys allows malicious actor to login with a forged JWT token (critical 9.8)
- [CVE-2023-22479](https://insights.sbomify.com/CVE-2023-22479/): KubePi vulnerable to session fixation attack (high 7.5)
- [CVE-2023-22478](https://insights.sbomify.com/CVE-2023-22478/): KubePi is vulnerable to missing authorization (high 7.3)
- [CVE-2023-37916](https://insights.sbomify.com/CVE-2023-37916/): Leak password hash of any user (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37917 and fix it if it is affected.

What it is: CVE-2023-37917 is a critical vulnerability in 1Panel-dev KubePi, published on 21 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37917 exists.

Affected packages and fixed versions:
- github.com/KubeOperator/kubepi (Go): affected all versions; fixed in 1.6.5
- github.com/KubeOperator/kubepi (Go): affected all versions; fixed in 1.6.5
- github.com/KubeOperator/kubepi (Go): affected all versions; fixed in 1.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37917/ (Markdown: https://insights.sbomify.com/CVE-2023-37917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37917
- OSV: https://osv.dev/vulnerability/CVE-2023-37917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37917/
Summaries are generated and may contain mistakes; the official description above is the record.
