# CVE-2023-37920: Certifi's removal of e-Tugra root certificate

> The library trusted compromised e-Tugra root certificates, allowing potential man-in-the-middle attacks; users should upgrade to remove these untrusted roots.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 5 Mar 2025
- **Also known as:** ALBA-2024:5736, ALPINE-CVE-2023-37920, AZL-35126, DEBIAN-CVE-2023-37920, GHSA-xqr8-7jwr-rhp7, MINI-7ff9-258m-35hf, MINI-q7v9-cwxc-6969, PYSEC-2023-135, RHBA-2024:5691, RHBA-2024:5736, ROOT-APP-PYPI-CVE-2023-37920, UBUNTU-CVE-2023-37920

## What is CVE-2023-37920?

CVE-2023-37920 is a high-severity vulnerability in Fedoraproject Fedora, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Certifi is a curated collection of Root Certificates for validating the trustworthiness of SSL certificates while verifying the identity of TLS hosts. Certifi prior to version 2023.07.22 recognizes "e-Tugra" root certificates. e-Tugra's root certificates were subject to an investigation prompted by reporting of security issues in their systems. Certifi 2023.07.22 removes root certificates from "e-Tugra" from the root store.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2023-37920?

3 open source packages ship an affected version, including certifi. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `certifi` | PyPI | From 2015.4.28 | 2023.7.22 |
| `certifi` | PyPI | From 2015.4.28 | 2023.7.22 |
| `certifi` | PyPI | From 2015.4.28 | 2023.7.22 |
| `ca-certificates` | AlmaLinux:8 | All versions | 2024.2.69_v8.0.303-80.0.el8_10 |
| `ca-certificates` | Red Hat:enterprise_linux:8::baseos | All versions | 0:2024.2.69_v8.0.303-80.0.el8_10 |
| `ca-certificates` | Red Hat:enterprise_linux:9::baseos | All versions | 0:2024.2.69_v8.0.303-91.4.el9_4 |

Products: Certifi Certifi, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Management Services for Element Software, Netapp Management Services for Netapp Hci, Netapp Ontap Mediator, Netapp Ontap Select Deploy Administration Utility, Netapp Solidfire \& Hci Storage Node.

## How do I fix CVE-2023-37920?

Upgrade certifi to 2023.7.22 or later.

## Is CVE-2023-37920 being exploited?

There is no known exploitation of CVE-2023-37920 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-39689](https://insights.sbomify.com/CVE-2024-39689/): Certifi removes GLOBALTRUST root certificate (high 7.5)
- [CVE-2022-23491](https://insights.sbomify.com/CVE-2022-23491/): Removal of TrustCor root certificate (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37920 and fix it if it is affected.

What it is: CVE-2023-37920 is a high-severity vulnerability in Fedoraproject Fedora, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37920 in the wild and no public exploit code.

Affected packages and fixed versions:
- certifi (PyPI): affected from 2015.4.28; fixed in 2023.7.22
- certifi (PyPI): affected from 2015.4.28; fixed in 2023.7.22
- certifi (PyPI): affected from 2015.4.28; fixed in 2023.7.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37920/ (Markdown: https://insights.sbomify.com/CVE-2023-37920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37920
- OSV: https://osv.dev/vulnerability/CVE-2023-37920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37920/
Summaries are generated and may contain mistakes; the official description above is the record.
