CVE-2023-37941 Apache Superset: Metadata db write access can lead to remote code execution
An attacker with write access to the metadata database can achieve remote code execution by persisting a crafted Python object.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-37941?
CVE-2023-37941 is a medium-severity unsafe deserialization vulnerability in Apache Superset, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend.
The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges.
This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.
Weakness: CWE-502
Which versions are affected by CVE-2023-37941?
4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-superset PyPI | From 1.5.0 | 2.1.1 |
apache-superset PyPI | From 1.5.0 | 2.1.1 |
apache-superset PyPI | From 1.5.0 | 2.1.1 |
superset Bitnami | From 1.5.0 | 2.1.1 |
Products include Apache Superset.
How do I fix CVE-2023-37941?
Upgrade apache-superset to 2.1.1 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2023-37941 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37941 exists.
Public exploit code: 1 Metasploit module and 1 proofs of concept on GitHub.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2023-37941, GHSA-fj4x-m62j-wvwg, PYSEC-2026-1175.