{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37941 exists.","fix":"Upgrade apache-superset to 2.1.1 or later.","what":"CVE-2023-37941 is a medium-severity unsafe deserialization vulnerability in Apache Superset, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-37941 and fix it if it is affected.\n\nWhat it is: CVE-2023-37941 is a medium-severity unsafe deserialization vulnerability in Apache Superset, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37941 exists.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected from 1.5.0; fixed in 2.1.1\n- apache-superset (PyPI): affected from 1.5.0; fixed in 2.1.1\n- apache-superset (PyPI): affected from 1.5.0; fixed in 2.1.1\n- superset (Bitnami): affected from 1.5.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-37941/ (Markdown: https://insights.sbomify.com/CVE-2023-37941/index.md)","id":"CVE-2023-37941","markdown":"https://insights.sbomify.com/CVE-2023-37941/index.md","name":"CVE-2023-37941","record":{"aliases":["BIT-superset-2023-37941","GHSA-fj4x-m62j-wvwg","PYSEC-2026-1175"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"high_privilege","summary":"An attacker with write access to the metadata database can achieve remote code execution by persisting a crafted Python object.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend.\n\nThe Superset metadata db is an 'internal' component that is typically \nonly accessible directly by the system administrator and the superset \nprocess itself. Gaining access to that database should\n be difficult and require significant privileges.\n\nThis vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":"2023-05-08","github_poc":1,"max_poc_stars":1,"metasploit":1,"nuclei":0,"refs":[{"date":"2023-05-08T13:55:30Z","kind":"github_poc","ref":"https://github.com/Barroqueiro/CVE-2023-37941","stars":1,"title":"Exploit on the default cache of superset by using pickle"},{"date":"2023-09-06","kind":"metasploit","ref":"exploit/linux/http/apache_superset_cookie_sig_rce","stars":null,"title":"Apache Superset Signed Cookie RCE"}],"tier":"weaponised"},"has_fix":true,"headline":"Apache Superset: Metadata db write access can lead to remote code execution","id":"CVE-2023-37941","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"deserialization","year":"2023"},"n_packages":4,"n_references":2,"next":{"headline":"Jenkins External Monitor Job Type Plugin XML external entity vulnerability","id":"CVE-2023-37942"},"packages":[{"ecosystem":"Bitnami","fixed":["2.1.1"],"introduced":["1.5.0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2023-37941"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["1.5.0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-fj4x-m62j-wvwg"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["1.5.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-fj4x-m62j-wvwg"},{"ecosystem":"PyPI","fixed":["2.1.1"],"introduced":["1.5.0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-1175"}],"prev":{"headline":"Liferay Portal and Liferay DXP have Cross-site Scripting vulnerability in edit Service Access Policy page","id":"CVE-2023-37940"},"products":["Apache Superset"],"published":"2023-09-06","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"An attacker with write access to the metadata database can achieve remote code execution by persisting a crafted Python object.","url":"https://insights.sbomify.com/CVE-2023-37941/"}