# CVE-2023-37941: Apache Superset: Metadata db write access can lead to remote code execution

> An attacker with write access to the metadata database can achieve remote code execution by persisting a crafted Python object.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-superset-2023-37941, GHSA-fj4x-m62j-wvwg, PYSEC-2026-1175

## What is CVE-2023-37941?

CVE-2023-37941 is a medium-severity unsafe deserialization vulnerability in Apache Superset, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend.

The Superset metadata db is an 'internal' component that is typically 
only accessible directly by the system administrator and the superset 
process itself. Gaining access to that database should
 be difficult and require significant privileges.

This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2023-37941?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | From 1.5.0 | 2.1.1 |
| `apache-superset` | PyPI | From 1.5.0 | 2.1.1 |
| `apache-superset` | PyPI | From 1.5.0 | 2.1.1 |
| `superset` | Bitnami | From 1.5.0 | 2.1.1 |

Products: Apache Superset.

## How do I fix CVE-2023-37941?

Upgrade apache-superset to 2.1.1 or later.

## Is CVE-2023-37941 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37941 exists.

Public exploit code:

- Exploit on the default cache of superset by using pickle (github_poc): https://github.com/Barroqueiro/CVE-2023-37941
- Apache Superset Signed Cookie RCE (metasploit)

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37941 and fix it if it is affected.

What it is: CVE-2023-37941 is a medium-severity unsafe deserialization vulnerability in Apache Superset, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-37941 exists.

Affected packages and fixed versions:
- apache-superset (PyPI): affected from 1.5.0; fixed in 2.1.1
- apache-superset (PyPI): affected from 1.5.0; fixed in 2.1.1
- apache-superset (PyPI): affected from 1.5.0; fixed in 2.1.1
- superset (Bitnami): affected from 1.5.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37941/ (Markdown: https://insights.sbomify.com/CVE-2023-37941/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37941
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37941
- OSV: https://osv.dev/vulnerability/CVE-2023-37941

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37941/
Summaries are generated and may contain mistakes; the official description above is the record.
