# CVE-2023-37944: Jenkins Datadog Plugin does not perform a permission check in an HTTP endpoint.

> Attackers with read access can capture Jenkins credentials by connecting to an attacker-controlled URL due to missing permission checks in the Datadog plugin.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2023
- **Updated:** 7 Nov 2024
- **Also known as:** GHSA-w3p4-7823-m33q

## What is CVE-2023-37944?

CVE-2023-37944 is a medium-severity missing authorization vulnerability in Jenkins Datadog Plugin, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Datadog Plugin 5.4.1 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2023-37944?

2 open source packages ship an affected version, including org.datadog.jenkins.plugins:datadog. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.datadog.jenkins.plugins:datadog` | Maven | All versions | 5.4.2 |
| `org.datadog.jenkins.plugins:datadog` | Maven | All versions | 5.4.2 |

Products: Jenkins Datadog.

## How do I fix CVE-2023-37944?

Upgrade org.datadog.jenkins.plugins:datadog to 5.4.2 or later.

## Is CVE-2023-37944 being exploited?

There is no known exploitation of CVE-2023-37944 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Datadog Plugin

- [CVE-2017-1000114](https://insights.sbomify.com/CVE-2017-1000114/): Exposure of Sensitive Information in Jenkins Datadog plugin (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37944 and fix it if it is affected.

What it is: CVE-2023-37944 is a medium-severity missing authorization vulnerability in Jenkins Datadog Plugin, published on 12 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37944 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.datadog.jenkins.plugins:datadog (Maven): affected all versions; fixed in 5.4.2
- org.datadog.jenkins.plugins:datadog (Maven): affected all versions; fixed in 5.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37944/ (Markdown: https://insights.sbomify.com/CVE-2023-37944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37944
- OSV: https://osv.dev/vulnerability/CVE-2023-37944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37944/
Summaries are generated and may contain mistakes; the official description above is the record.
