# CVE-2023-37948: Jenkins Oracle Cloud Infrastructure Compute Plugin missing SSH host key validation

> Attackers can perform man-in-the-middle attacks against Jenkins OCI cloud connections due to missing SSH host key validation.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2023
- **Updated:** 6 Nov 2024
- **Also known as:** GHSA-j54r-w587-95q7

## What is CVE-2023-37948?

CVE-2023-37948 is a low-severity vulnerability in Jenkins Oracle Cloud Infrastructure Compute Plugin, published on 12 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Oracle Cloud Infrastructure Compute Plugin 1.0.16 and earlier does not validate SSH host keys when connecting OCI clouds, enabling man-in-the-middle attacks.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2023-37948?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:oracle-cloud-infrastructure-compute. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:oracle-cloud-infrastructure-compute` | Maven | All versions | 1.0.17 |
| `org.jenkins-ci.plugins:oracle-cloud-infrastructure-compute` | Maven | All versions | 1.0.17 |

Products: Jenkins Cloud Infrastructure Compute.

## How do I fix CVE-2023-37948?

Upgrade org.jenkins-ci.plugins:oracle-cloud-infrastructure-compute to 1.0.17 or later.

## Is CVE-2023-37948 being exploited?

There is no known exploitation of CVE-2023-37948 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-37948 and fix it if it is affected.

What it is: CVE-2023-37948 is a low-severity vulnerability in Jenkins Oracle Cloud Infrastructure Compute Plugin, published on 12 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-37948 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:oracle-cloud-infrastructure-compute (Maven): affected all versions; fixed in 1.0.17
- org.jenkins-ci.plugins:oracle-cloud-infrastructure-compute (Maven): affected all versions; fixed in 1.0.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-37948/ (Markdown: https://insights.sbomify.com/CVE-2023-37948/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-37948
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-37948
- OSV: https://osv.dev/vulnerability/CVE-2023-37948

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-37948/
Summaries are generated and may contain mistakes; the official description above is the record.
