CVE-2023-38000 Auth. Stored Cross-Site Scripting (XSS) vulnerability in WordPress core and Gutenberg plugin via Navigation Links Block
Authenticated contributors can inject malicious scripts via the Navigation Links Block, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-38000?
CVE-2023-38000 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 13 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugin <= 16.8.0 versions.
Weakness: CWE-79
Which versions are affected by CVE-2023-38000?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | From 5.9.0 | 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2 |
wordpress-multisite Bitnami | From 5.9.0 | 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2 |
Products include Wordpress Gutenberg, Wordpress Wordpress.
How do I fix CVE-2023-38000?
Upgrade wordpress to a fixed version for your release line: 5.9.8, 6.0.6, 6.1.4 or 6.2.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-38000 being exploited?
There is no known exploitation of CVE-2023-38000 in the wild and no public exploit code.
Sources
Also known as BIT-wordpress-2023-38000, BIT-wordpress-multisite-2023-38000, DEBIAN-CVE-2023-38000, GHSA-ggq5-xv35-rxhf, UBUNTU-CVE-2023-38000.