{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.","exploited":"There is no known exploitation of CVE-2023-38000 in the wild and no public exploit code.","fix":"Upgrade wordpress to a fixed version for your release line: 5.9.8, 6.0.6, 6.1.4 or 6.2.3.","what":"CVE-2023-38000 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 13 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2023-38000 and fix it if it is affected.\n\nWhat it is: CVE-2023-38000 is a medium-severity cross-site scripting vulnerability in Wordpress Wordpress, published on 13 Oct 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2023-38000 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 5.9.0; fixed in 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2\n- wordpress-multisite (Bitnami): affected from 5.9.0; fixed in 5.9.8, 6.0.6, 6.1.4, 6.2.3, 6.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38000/ (Markdown: https://insights.sbomify.com/CVE-2023-38000/index.md)","id":"CVE-2023-38000","markdown":"https://insights.sbomify.com/CVE-2023-38000/index.md","name":"CVE-2023-38000","record":{"aliases":["BIT-wordpress-2023-38000","BIT-wordpress-multisite-2023-38000","DEBIAN-CVE-2023-38000","GHSA-ggq5-xv35-rxhf","UBUNTU-CVE-2023-38000"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"low_privilege","summary":"Authenticated contributors can inject malicious scripts via the Navigation Links Block, potentially leading to code execution or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Patchstack","cpe":[{"product":"gutenberg","vendor":"wordpress"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Auth. Stored (contributor+) Cross-Site Scripting (XSS) vulnerability in WordPress core 6.3 through 6.3.1, from 6.2 through 6.2.2, from 6.1 through 6.1.3, from 6.0 through 6.0.5, from 5.9 through 5.9.7 and Gutenberg plugin \u003c= 16.8.0 versions.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth. Stored Cross-Site Scripting (XSS) vulnerability in WordPress core and Gutenberg plugin via Navigation Links Block","id":"CVE-2023-38000","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":"xss","year":"2023"},"n_packages":2,"n_references":3,"next":{"headline":"IBM Aspera Orchestrator cross-site request forgery","id":"CVE-2023-38001"},"packages":[{"ecosystem":"Bitnami","fixed":["5.9.8","6.0.6","6.1.4","6.2.3","6.3.2"],"introduced":["5.9.0","6.0.0","6.1.0","6.2.0","6.3.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2023-38000"},{"ecosystem":"Bitnami","fixed":["5.9.8","6.0.6","6.1.4","6.2.3","6.3.2"],"introduced":["5.9.0","6.0.0","6.1.0","6.2.0","6.3.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2023-38000"}],"prev":{"headline":"WordPress HT Mega Absolute Addons for Elementor plugin \u003c= 2.2.0 - Unauthenticated Privilege Escalation vulnerability","id":"CVE-2023-37999"},"products":["Gutenberg","WordPress"],"published":"2023-10-13","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2026-04-28","vendors":["Gutenberg Team","WordPress.org"]},"summary":"Authenticated contributors can inject malicious scripts via the Navigation Links Block, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2023-38000/"}