# CVE-2023-38201: Keylime: challenge-response protocol bypass during agent registration

> Attackers can bypass challenge-response checks to impersonate agents, compromising registrar database integrity and hiding machine status.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2023
- **Updated:** 20 Nov 2025
- **Also known as:** GHSA-f4r5-q63f-gcww, PYSEC-2023-160, SUSE-SU-2023:3525-1, openSUSE-SU-2024:13287-1

## What is CVE-2023-38201?

CVE-2023-38201 is a medium-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 25 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in the Keylime registrar that could allow a bypass of the challenge-response protocol during agent registration. This issue may allow an attacker to impersonate an agent and hide the true status of a monitored machine if the fake agent is added to the verifier list by a legitimate user, resulting in a breach of the integrity of the registrar database.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2023-38201?

3 open source packages ship an affected version, including keylime. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keylime` | PyPI | All versions | 7.5.0 |
| `keylime` | PyPI | All versions | 7.5.0 |
| `keylime` | PyPI | All versions | 7.5.0 |
| `keylime` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 6.3.2-150400.4.20.1 |
| `keylime` | SUSE:Linux Enterprise Module for Basesystem 15 SP5 | All versions | 6.3.2-150400.4.20.1 |
| `keylime` | openSUSE:Leap 15.4 | All versions | 6.3.2-150400.4.20.1 |
| `keylime` | openSUSE:Leap 15.5 | All versions | 6.3.2-150400.4.20.1 |

Products: Fedoraproject Fedora, Keylime Keylime, Redhat Enterprise Linux, Redhat Enterprise Linux Eus, Redhat Enterprise Linux for Ibm Z Systems, Redhat Enterprise Linux for Ibm Z Systems Eus, Redhat Enterprise Linux for Power Little Endian, Redhat Enterprise Linux for Power Little Endian Eus, Redhat Enterprise Linux Server Aus.

## How do I fix CVE-2023-38201?

Upgrade keylime to 7.5.0 or later.

## Is CVE-2023-38201 being exploited?

There is no known exploitation of CVE-2023-38201 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38201 and fix it if it is affected.

What it is: CVE-2023-38201 is a medium-severity authentication bypass vulnerability in Fedoraproject Fedora, published on 25 Aug 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-38201 in the wild and no public exploit code.

Affected packages and fixed versions:
- keylime (PyPI): affected all versions; fixed in 7.5.0
- keylime (PyPI): affected all versions; fixed in 7.5.0
- keylime (PyPI): affected all versions; fixed in 7.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38201/ (Markdown: https://insights.sbomify.com/CVE-2023-38201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38201
- OSV: https://osv.dev/vulnerability/CVE-2023-38201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38201/
Summaries are generated and may contain mistakes; the official description above is the record.
