CVE-2023-3823 Security issue with external entity loading in XML without enabling it
Attackers can read local files via XML external entity injection when libxml global state is altered by other modules like ImageMagick.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3823?
CVE-2023-3823 is a high-severity vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* before 8.2.8 various XML functions rely on libxml global state to track configuration variables, like whether external entities are loaded. This state is assumed to be unchanged unless the user explicitly changes it by calling appropriate function. However, since the state is process-global, other modules - such as ImageMagick - may also use this library within the same process, and change that global state for their internal purposes, and leave it in a state where external entities loading is enabled. This can lead to the situation where external XML is parsed with external entities loaded, which can lead to disclosure of any local files accessible to PHP. This vulnerable state may persist in the same process across many requests, until the process is shut down.
Weakness: CWE-611
Which versions are affected by CVE-2023-3823?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
php Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
php-min Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
Products include Debian Debian Linux, Fedoraproject Fedora, Php Php.
How do I fix CVE-2023-3823?
Upgrade libphp to a fixed version for your release line: 8.0.30, 8.1.22 or 8.2.9.
Is CVE-2023-3823 being exploited?
There is no known exploitation of CVE-2023-3823 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-27962, AZL-63085, BIT-libphp-2023-3823, BIT-php-2023-3823, BIT-php-min-2023-3823, CLSA-2024-1734535703 and 5 more.