# CVE-2023-3823: Security issue with external entity loading in XML without enabling it

> Attackers can read local files via XML external entity injection when libxml global state is altered by other modules like ImageMagick.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-27962, AZL-63085, BIT-libphp-2023-3823, BIT-php-2023-3823, BIT-php-min-2023-3823, CLSA-2024-1734535703, DEBIAN-CVE-2023-3823, ECHO-6887-6df9-00ab, GHSA-3qrf-m4j2-pcrr, UBUNTU-CVE-2023-3823, USN-6305-3

## What is CVE-2023-3823?

CVE-2023-3823 is a high-severity vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* before 8.2.8 various XML functions rely on libxml global state to track configuration variables, like whether external entities are loaded. This state is assumed to be unchanged unless the user explicitly changes it by calling appropriate function. However, since the state is process-global, other modules - such as ImageMagick - may also use this library within the same process, and change that global state for their internal purposes, and leave it in a state where external entities loading is enabled. This can lead to the situation where external XML is parsed with external entities loaded, which can lead to disclosure of any local files accessible to PHP. This vulnerable state may persist in the same process across many requests, until the process is shut down.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-3823?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
| `php` | Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
| `php-min` | Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |

Products: Debian Debian Linux, Fedoraproject Fedora, Php Php.

## How do I fix CVE-2023-3823?

Upgrade libphp to a fixed version for your release line: 8.0.30, 8.1.22 or 8.2.9.

## Is CVE-2023-3823 being exploited?

There is no known exploitation of CVE-2023-3823 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3823 and fix it if it is affected.

What it is: CVE-2023-3823 is a high-severity vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3823 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9
- php (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9
- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3823/ (Markdown: https://insights.sbomify.com/CVE-2023-3823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3823
- OSV: https://osv.dev/vulnerability/CVE-2023-3823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3823/
Summaries are generated and may contain mistakes; the official description above is the record.
