CVE-2023-3824 Buffer overflow and overread in phar_dir_read()
A stack buffer overflow in PHP's phar_dir_read function allows attackers to potentially execute arbitrary code or cause denial of service via crafted PHAR files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-3824?
CVE-2023-3824 is a critical memory corruption vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP version 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* before 8.2.8, when loading phar file, while reading PHAR directory entries, insufficient length checking may lead to a stack buffer overflow, leading potentially to memory corruption or RCE.
Weakness: CWE-119
Which versions are affected by CVE-2023-3824?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
php Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
php-min Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
Linux distribution packages (1)
php8 openSUSE:Tumbleweed | All versions | 8.2.9-1.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Php Php.
How do I fix CVE-2023-3824?
Upgrade libphp to a fixed version for your release line: 8.0.30, 8.1.22 or 8.2.9.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2023-3824 being exploited?
There is no known exploitation of CVE-2023-3824 in the wild and no public exploit code.
Public exploit code: 3 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as AZL-27943, AZL-63070, BIT-libphp-2023-3824, BIT-php-2023-3824, BIT-php-min-2023-3824, CLSA-2024-1734368090 and 5 more.