{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.","exploited":"There is no known exploitation of CVE-2023-3824 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 8.0.30, 8.1.22 or 8.2.9.","what":"CVE-2023-3824 is a critical memory corruption vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-3824 and fix it if it is affected.\n\nWhat it is: CVE-2023-3824 is a critical memory corruption vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-3824 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9\n- php (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9\n- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-3824/ (Markdown: https://insights.sbomify.com/CVE-2023-3824/index.md)","id":"CVE-2023-3824","markdown":"https://insights.sbomify.com/CVE-2023-3824/index.md","name":"CVE-2023-3824","record":{"aliases":["AZL-27943","AZL-63070","BIT-libphp-2023-3824","BIT-php-2023-3824","BIT-php-min-2023-3824","CLSA-2024-1734368090","DEBIAN-CVE-2023-3824","ECHO-5798-8681-2227","GHSA-jqcx-ccgc-xwhv","UBUNTU-CVE-2023-3824","openSUSE-SU-2024:13153-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP scripting language","requires_auth":"none","summary":"A stack buffer overflow in PHP's phar_dir_read function allows attackers to potentially execute arbitrary code or cause denial of service via crafted PHAR files.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"php","vendor":"php"}],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"In PHP version 8.0.* before 8.0.30,  8.1.* before 8.1.22, and 8.2.* before 8.2.8, when loading phar file, while reading PHAR directory entries, insufficient length checking may lead to a stack buffer overflow, leading potentially to memory corruption or RCE.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2024-03-18","github_poc":3,"max_poc_stars":3,"metasploit":0,"nuclei":0,"refs":[{"date":"2024-03-18T10:45:33Z","kind":"github_poc","ref":"https://github.com/jhonnybonny/CVE-2023-3824","stars":3,"title":"Vulnerability in PHP Phar files, due to buffer overflow, arises from insufficient length checks on file names within the Phar archive. Malicious actors can craft Phar files with long file names, leading to buffer overflow and potential execution of malicious code or data leakage. This vulnerability can be exploited for code execution CVE-2023-3824"},{"date":"2025-01-11T17:19:21Z","kind":"github_poc","ref":"https://github.com/bluefish3r/poc-cve","stars":0,"title":"poc-cve-2023-3824"},{"date":"2025-09-23T03:52:06Z","kind":"github_poc","ref":"https://github.com/dadosneurais/cve-2023-3824","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"Buffer overflow and overread in phar_dir_read()","id":"CVE-2023-3824","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","php:php"],"type":"memory_corruption","year":"2023"},"n_packages":4,"n_references":4,"next":{"headline":"Denial of service in KEPServerEX","id":"CVE-2023-3825"},"packages":[{"ecosystem":"Bitnami","fixed":["8.0.30","8.1.22","8.2.9"],"introduced":["8.0.0","8.1.0","8.2.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2023-3824"},{"ecosystem":"Bitnami","fixed":["8.0.30","8.1.22","8.2.9"],"introduced":["8.0.0","8.1.0","8.2.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2023-3824"},{"ecosystem":"Bitnami","fixed":["8.0.30","8.1.22","8.2.9"],"introduced":["8.0.0","8.1.0","8.2.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2023-3824"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["8.2.9-1.1"],"introduced":["0"],"last_affected":[],"package":"php8","purl":"pkg:rpm/opensuse/php8\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13153-1"}],"prev":{"headline":"Security issue with external entity loading in XML without enabling it","id":"CVE-2023-3823"},"products":["PHP"],"published":"2023-08-11","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-02-13","vendors":["PHP Group"]},"summary":"A stack buffer overflow in PHP's phar_dir_read function allows attackers to potentially execute arbitrary code or cause denial of service via crafted PHAR files.","url":"https://insights.sbomify.com/CVE-2023-3824/"}