# CVE-2023-3824: Buffer overflow and overread in phar_dir_read()

> A stack buffer overflow in PHP's phar_dir_read function allows attackers to potentially execute arbitrary code or cause denial of service via crafted PHAR files.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Aug 2023
- **Updated:** 13 Feb 2025
- **Also known as:** AZL-27943, AZL-63070, BIT-libphp-2023-3824, BIT-php-2023-3824, BIT-php-min-2023-3824, CLSA-2024-1734368090, DEBIAN-CVE-2023-3824, ECHO-5798-8681-2227, GHSA-jqcx-ccgc-xwhv, UBUNTU-CVE-2023-3824, openSUSE-SU-2024:13153-1

## What is CVE-2023-3824?

CVE-2023-3824 is a critical memory corruption vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP version 8.0.* before 8.0.30,  8.1.* before 8.1.22, and 8.2.* before 8.2.8, when loading phar file, while reading PHAR directory entries, insufficient length checking may lead to a stack buffer overflow, leading potentially to memory corruption or RCE.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2023-3824?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
| `php` | Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
| `php-min` | Bitnami | From 8.0.0 | 8.0.30, 8.1.22, 8.2.9 |
| `php8` | openSUSE:Tumbleweed | All versions | 8.2.9-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Php Php.

## How do I fix CVE-2023-3824?

Upgrade libphp to a fixed version for your release line: 8.0.30, 8.1.22 or 8.2.9.

## Is CVE-2023-3824 being exploited?

There is no known exploitation of CVE-2023-3824 in the wild and no public exploit code.

Public exploit code:

- Vulnerability in PHP Phar files, due to buffer overflow, arises from insufficient length checks on file names within the Phar archive. Malicious actors can craft Phar files with long file names, leading to buffer overflow and potential execution of malicious code or data leakage. This vulnerability can be exploited for code execution CVE-2023-3824 (github_poc): https://github.com/jhonnybonny/CVE-2023-3824
- poc-cve-2023-3824 (github_poc): https://github.com/bluefish3r/poc-cve
- https://github.com/dadosneurais/cve-2023-3824 (github_poc): https://github.com/dadosneurais/cve-2023-3824

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-3824 and fix it if it is affected.

What it is: CVE-2023-3824 is a critical memory corruption vulnerability in Debian Debian Linux, published on 11 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-3824 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9
- php (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9
- php-min (Bitnami): affected from 8.0.0; fixed in 8.0.30, 8.1.22, 8.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-3824/ (Markdown: https://insights.sbomify.com/CVE-2023-3824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-3824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-3824
- OSV: https://osv.dev/vulnerability/CVE-2023-3824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-3824/
Summaries are generated and may contain mistakes; the official description above is the record.
