{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38283 exists.","fix":"Apply the vendor's patch.","what":"CVE-2023-38283 is a medium-severity denial of service vulnerability in n/a, published on 29 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-38283 and fix it if it is affected.\n\nWhat it is: CVE-2023-38283 is a medium-severity denial of service vulnerability in n/a, published on 29 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38283 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38283/ (Markdown: https://insights.sbomify.com/CVE-2023-38283/index.md)","id":"CVE-2023-38283","markdown":"https://insights.sbomify.com/CVE-2023-38283/index.md","name":"CVE-2023-38283","record":{"aliases":["DEBIAN-CVE-2023-38283","GHSA-q32v-3jr9-xvmc","UBUNTU-CVE-2023-38283"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"BGP routing daemon","requires_auth":"none","summary":"A remote attacker can cause a denial of service by sending malformed BGP update data, requiring a patch to OpenBGPD.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openbgpd","vendor":"openbgpd"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-754","name":"Improper Check for Unusual or Exceptional Conditions"}],"description":"In OpenBGPD before 8.1, incorrect handling of BGP update data (length of path attributes) set by a potentially distant remote actor may cause the system to incorrectly reset a session. This is fixed in OpenBSD 7.3 errata 006.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2023-38283","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":0,"n_references":5,"next":{"headline":"Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity.","id":"CVE-2023-38285"},"packages":[],"prev":{"headline":"Multiple Vulnerabilities in IBM Cloud Pak System","id":"CVE-2023-38281"},"products":["n/a"],"published":"2023-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-02","vendors":["n/a"]},"summary":"A remote attacker can cause a denial of service by sending malformed BGP update data, requiring a patch to OpenBGPD.","url":"https://insights.sbomify.com/CVE-2023-38283/"}