# CVE-2023-38283: Denial of service in n/a

> A remote attacker can cause a denial of service by sending malformed BGP update data, requiring a patch to OpenBGPD.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2023
- **Updated:** 2 Oct 2024
- **Also known as:** DEBIAN-CVE-2023-38283, GHSA-q32v-3jr9-xvmc, UBUNTU-CVE-2023-38283

## What is CVE-2023-38283?

CVE-2023-38283 is a medium-severity denial of service vulnerability in n/a, published on 29 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In OpenBGPD before 8.1, incorrect handling of BGP update data (length of path attributes) set by a potentially distant remote actor may cause the system to incorrectly reset a session. This is fixed in OpenBSD 7.3 errata 006.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2023-38283?

It affects 1 product.


Products: Openbgpd Openbgpd.

## How do I fix CVE-2023-38283?

Apply the vendor's patch.

## Is CVE-2023-38283 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38283 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38283 and fix it if it is affected.

What it is: CVE-2023-38283 is a medium-severity denial of service vulnerability in n/a, published on 29 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38283 exists.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38283/ (Markdown: https://insights.sbomify.com/CVE-2023-38283/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38283
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38283
- OSV: https://osv.dev/vulnerability/CVE-2023-38283

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38283/
Summaries are generated and may contain mistakes; the official description above is the record.
