# CVE-2023-38285: Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity.


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Jul 2023
- **Updated:** 23 Oct 2024
- **Also known as:** BIT-modsecurity-2023-38285, BIT-modsecurity2-2023-38285, DEBIAN-CVE-2023-38285, GHSA-wf6m-89q7-h9jh, UBUNTU-CVE-2023-38285, openSUSE-SU-2024:13195-1

## What is CVE-2023-38285?

CVE-2023-38285 is a high-severity vulnerability in n/a, published on 26 Jul 2023. 

### Official description

Trustwave ModSecurity 3.x before 3.0.10 has Inefficient Algorithmic Complexity.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2023-38285?

2 open source packages ship an affected version, including modsecurity and modsecurity2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `modsecurity` | Bitnami | From 3.0.0 | 3.0.10 |
| `modsecurity2` | Bitnami | From 3.0.0 | 3.0.10 |

Products: Owasp Modsecurity.

## How do I fix CVE-2023-38285?

Upgrade modsecurity to 3.0.10 or later.

## Is CVE-2023-38285 being exploited?

There is no known exploitation of CVE-2023-38285 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-52747](https://insights.sbomify.com/CVE-2026-52747/): Security feature bypass in ModSecurity (high 8.6)
- [CVE-2024-1019](https://insights.sbomify.com/CVE-2024-1019/): WAF bypass of the ModSecurity v3 release line (high 8.6)
- [CVE-2026-42268](https://insights.sbomify.com/CVE-2026-42268/): ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators (high 8.2)
- [CVE-2026-30923](https://insights.sbomify.com/CVE-2026-30923/): libModSecurity3 denial of service via segfault when using t:hexDecode on single-character query strings (high 8.2)
- [CVE-2025-48866](https://insights.sbomify.com/CVE-2025-48866/): ModSecurity has possible DoS vulnerability in sanitiseArg action (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38285 and fix it if it is affected.

What it is: CVE-2023-38285 is a high-severity vulnerability in n/a, published on 26 Jul 2023. 
Exploitation: There is no known exploitation of CVE-2023-38285 in the wild and no public exploit code.

Affected packages and fixed versions:
- modsecurity (Bitnami): affected from 3.0.0; fixed in 3.0.10
- modsecurity2 (Bitnami): affected from 3.0.0; fixed in 3.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38285/ (Markdown: https://insights.sbomify.com/CVE-2023-38285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38285
- OSV: https://osv.dev/vulnerability/CVE-2023-38285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38285/
Summaries are generated and may contain mistakes; the official description above is the record.
