# CVE-2023-38314: Null dereference in n/a

> A crafted HTTP request causes a null pointer dereference in OpenNDS, leading to a denial-of-service crash.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2023
- **Updated:** 2 Aug 2024
- **Also known as:** DEBIAN-CVE-2023-38314, GHSA-9752-mq4c-65h9

## What is CVE-2023-38314?

CVE-2023-38314 is a medium-severity vulnerability in n/a, published on 17 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in OpenNDS Captive Portal before version 10.1.2. It has a NULL pointer dereference in preauthenticated() that can be triggered with a crafted GET HTTP request with a missing redirect query string parameter. Triggering this issue results in crashing OpenNDS (a Denial-of-Service condition). Affected OpenNDS Captive Portal before version 10.1.2 fixed infixed in OpenWrt master, OpenWrt 23.05 and OpenWrt 22.03 on28. August 2023 by updating OpenNDS to version 10.1.3.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2023-38314?

It affects 1 product.


Products: Opennds Captive Portal.

## How do I fix CVE-2023-38314?

Upgrade to a fixed version.

## Is CVE-2023-38314 being exploited?

There is no known exploitation of CVE-2023-38314 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-38316](https://insights.sbomify.com/CVE-2023-38316/): Command injection in n/a (critical 9.8)
- [CVE-2023-38313](https://insights.sbomify.com/CVE-2023-38313/): Null dereference in n/a (high 7.5)
- [CVE-2023-38315](https://insights.sbomify.com/CVE-2023-38315/): Null dereference in n/a (high 7.5)
- [CVE-2023-38320](https://insights.sbomify.com/CVE-2023-38320/): Null dereference in n/a (high 7.5)
- [CVE-2023-38322](https://insights.sbomify.com/CVE-2023-38322/): Null dereference in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38314 and fix it if it is affected.

What it is: CVE-2023-38314 is a medium-severity vulnerability in n/a, published on 17 Nov 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-38314 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38314/ (Markdown: https://insights.sbomify.com/CVE-2023-38314/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38314
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38314
- OSV: https://osv.dev/vulnerability/CVE-2023-38314

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38314/
Summaries are generated and may contain mistakes; the official description above is the record.
