{"answers":{"affected":"3 open source packages ship an affected version, including cryptography. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38325 exists.","fix":"Upgrade cryptography to 41.0.2 or later.","what":"CVE-2023-38325 is a high-severity vulnerability in n/a, published on 14 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-38325 and fix it if it is affected.\n\nWhat it is: CVE-2023-38325 is a high-severity vulnerability in n/a, published on 14 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38325 exists.\n\nAffected packages and fixed versions:\n- cryptography (PyPI): affected from 40.0.0; fixed in 41.0.2\n- cryptography (PyPI): affected from 40.0.0; fixed in 41.0.2\n- cryptography (PyPI): affected from 40.0.0; fixed in 41.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38325/ (Markdown: https://insights.sbomify.com/CVE-2023-38325/index.md)","id":"CVE-2023-38325","markdown":"https://insights.sbomify.com/CVE-2023-38325/index.md","name":"CVE-2023-38325","record":{"aliases":["ALPINE-CVE-2023-38325","GHSA-cf7p-gm2m-833m","PYSEC-2023-112","openSUSE-SU-2024:13078-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"The Python cryptography library mishandles SSH certificates with critical options, allowing attackers to bypass security checks.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cryptography","vendor":"cryptography.io"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"The cryptography package before 41.0.2 for Python mishandles SSH certificates that have critical options.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"cryptography mishandles SSH certificates","id":"CVE-2023-38325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2023"},"n_packages":4,"n_references":6,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2023-38326"},"packages":[{"ecosystem":"PyPI","fixed":["41.0.2"],"introduced":["40.0.0"],"last_affected":[],"package":"cryptography","purl":null,"source":"GHSA-cf7p-gm2m-833m"},{"ecosystem":"PyPI","fixed":["41.0.2"],"introduced":["40.0.0"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"GHSA-cf7p-gm2m-833m"},{"ecosystem":"PyPI","fixed":["41.0.2"],"introduced":["40.0.0"],"last_affected":[],"package":"cryptography","purl":"pkg:pypi/cryptography","source":"PYSEC-2023-112"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["41.0.2-2.1"],"introduced":["0"],"last_affected":[],"package":"python-cryptography","purl":"pkg:rpm/opensuse/python-cryptography\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:13078-1"}],"prev":{"headline":"Auth bypass in n/a","id":"CVE-2023-38324"},"products":["n/a"],"published":"2023-07-14","related":[{"cvss_score":9.1,"headline":"PyCA Cryptography symmetrically encrypting large values can lead to integer overflow","id":"CVE-2020-36242","kev_date_added":null,"published":"2021-02-07"},{"cvss_score":8.2,"headline":"cryptography Subgroup Attack Due to Missing Subgroup Validation for SECT Curves","id":"CVE-2026-26007","kev_date_added":null,"published":"2026-02-10"},{"cvss_score":7.5,"headline":"cryptography NULL pointer dereference with pkcs12.serialize_key_and_certificates when called with a non-matching certificate and private key and an hmac_hash override","id":"CVE-2024-26130","kev_date_added":null,"published":"2024-02-21"},{"cvss_score":6.9,"headline":"cryptography has a buffer overflow if non-contiguous buffers were passed to APIs","id":"CVE-2026-39892","kev_date_added":null,"published":"2026-04-08"},{"cvss_score":5.9,"headline":"cryptography vulnerable to NULL-dereference when loading PKCS7 certificates","id":"CVE-2023-49083","kev_date_added":null,"published":"2023-11-29"},{"cvss_score":5.9,"headline":"RSA decryption vulnerable to Bleichenbacher timing vulnerability","id":"CVE-2020-25659","kev_date_added":null,"published":"2021-01-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-30","vendors":["n/a"]},"summary":"The Python cryptography library mishandles SSH certificates with critical options, allowing attackers to bypass security checks.","url":"https://insights.sbomify.com/CVE-2023-38325/"}