CVE-2023-38488 Kirby vulnerable to field injection in the KirbyData text storage handler
Authenticated users or visitors with write access can inject malicious data or code into Kirby content files via Unicode BOM manipulation in field separators.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2023-38488?
CVE-2023-38488 is a high-severity code injection vulnerability in getkirby kirby, published on 27 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update a Kirby content file (e.g. via a contact or comment form). Kirby sites are *not* affected if they don't allow write access for untrusted users or visitors.
A field injection in a content storage implementation is a type of vulnerability that allows attackers with content write access to overwrite content fields that the site developer didn't intend to be modified. In a Kirby site this can be used to alter site content, break site behavior or inject malicious data or code. The exact security risk depends on the field type and usage.
Kirby stores content of the site, of pages, files and users in text files by default. The text files use Kirby's KirbyData format where each field is separated by newlines and a line with four dashes (`----`). When reading a KirbyData file, the affected code first removed the Unicode BOM sequence from the file contents and afterwards split the content into fields by the field separator.
When writing to a KirbyData file, field separators in field data are escaped to prevent user input from interfering with the field structure. However this escaping could be tricked by including a Unicode BOM sequence in a field separator (e.g. `--\xEF\xBB\xBF--`). When writing, this was not detected as a separator, but because the BOM was removed during reading, it could be abused by attackers to inject other field data into content files.
Because each field can only be defined once per content file, this vulnerability only affects fields in the content file that were defined above the vulnerable user-writable field or not at all. Fields that are defined below the vulnerable field override the injected field content and were therefore already protected.
The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have fixed the affected code to only remove the Unicode BOM sequence at the beginning of the file. This fixes this vulnerability both for newly written as well as for existing content files.
Which versions are affected by CVE-2023-38488?
10 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 3.5.8.3 |
getkirby/cms Packagist | All versions | 3.5.8.3 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.3 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.3 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.2 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.2 |
4 more packages
getkirby/cms Packagist | From 3.8.0 | 3.8.4.1 |
getkirby/cms Packagist | From 3.8.0 | 3.8.4.1 |
getkirby/cms Packagist | From 3.9.0 | 3.9.6 |
getkirby/cms Packagist | From 3.9.0 | 3.9.6 |
Products include Getkirby Kirby.
How do I fix CVE-2023-38488?
Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.3, 3.6.6.3, 3.7.5.2 or 3.8.4.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2023-38488 being exploited?
There is no known exploitation of CVE-2023-38488 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-x5mr-p6v4-wp93.