# CVE-2023-38489: Kirby vulnerable to Insufficient Session Expiration after a password change

> Attackers can maintain unauthorized access to Kirby CMS accounts after password changes due to insufficient session expiration, requiring a patch to invalidate old sessions.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2023
- **Updated:** 23 Oct 2024
- **Also known as:** GHSA-5mvj-rvp8-rf45

## What is CVE-2023-38489?

CVE-2023-38489 is a high-severity authentication bypass vulnerability in getkirby kirby, published on 27 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). It can only be abused if a Kirby user is logged in on a device or browser that is shared with potentially untrusted users or if an attacker already maliciously used a previous password to log in to a Kirby site as the affected user.

Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization. In the variation described in this advisory, it allows attackers to stay logged in to a Kirby site on another device even if the logged in user has since changed their password. Kirby did not invalidate user sessions that were created with a password that was since changed by the user or by a site admin. If a user changed their password to lock out an attacker who was already in possession of the previous password or of a login session on another device or browser, the attacker would not be reliably prevented from accessing the Kirby site as the affected user.

The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have updated the authentication implementation to keep track of the hashed password in each active session. If the password changed since the login, the session is invalidated. To enforce this fix even if the vulnerability was previously abused, all users are logged out from the Kirby site after updating to one of the patched releases.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2023-38489?

10 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 3.5.8.3 |
| `getkirby/cms` | Packagist | All versions | 3.5.8.3 |
| `getkirby/cms` | Packagist | From 3.6.0 | 3.6.6.3 |
| `getkirby/cms` | Packagist | From 3.6.0 | 3.6.6.3 |
| `getkirby/cms` | Packagist | From 3.7.0 | 3.7.5.2 |
| `getkirby/cms` | Packagist | From 3.7.0 | 3.7.5.2 |
| `getkirby/cms` | Packagist | From 3.8.0 | 3.8.4.1 |
| `getkirby/cms` | Packagist | From 3.8.0 | 3.8.4.1 |
| `getkirby/cms` | Packagist | From 3.9.0 | 3.9.6 |
| `getkirby/cms` | Packagist | From 3.9.0 | 3.9.6 |

Products: Getkirby Kirby.

## How do I fix CVE-2023-38489?

Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.3, 3.6.6.3, 3.7.5.2 or 3.8.4.1.

## Is CVE-2023-38489 being exploited?

There is no known exploitation of CVE-2023-38489 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2021-41252](https://insights.sbomify.com/CVE-2021-41252/): Cross-site scripting (XSS) from writer field content in the site frontend (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38489 and fix it if it is affected.

What it is: CVE-2023-38489 is a high-severity authentication bypass vulnerability in getkirby kirby, published on 27 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2023-38489 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.3
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.3
- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.3
- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.3
- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.2
- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.2
- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.4.1
- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.4.1
- getkirby/cms (Packagist): affected from 3.9.0; fixed in 3.9.6
- getkirby/cms (Packagist): affected from 3.9.0; fixed in 3.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38489/ (Markdown: https://insights.sbomify.com/CVE-2023-38489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38489
- OSV: https://osv.dev/vulnerability/CVE-2023-38489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38489/
Summaries are generated and may contain mistakes; the official description above is the record.
