CVE-2023-38490 Kirby XML External Entity (XXE) vulnerability in the XML data handler
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2023-38490?
CVE-2023-38490 is a medium-severity vulnerability in getkirby kirby, published on 27 Jul 2023.
Official description
Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 only affects Kirby sites that use the `Xml` data handler (e.g. `Data::decode($string, 'xml')`) or the `Xml::parse()` method in site or plugin code. The Kirby core does not use any of the affected methods.
XML External Entities (XXE) is a little used feature in the XML markup language that allows to include data from external files in an XML structure. If the name of the external file can be controlled by an attacker, this becomes a vulnerability that can be abused for various system impacts like the disclosure of internal or confidential data that is stored on the server (arbitrary file disclosure) or to perform network requests on behalf of the server (server-side request forgery, SSRF).
Kirby's `Xml::parse()` method used PHP's `LIBXML_NOENT` constant, which enabled the processing of XML external entities during the parsing operation. The `Xml::parse()` method is used in the `Xml` data handler (e.g. `Data::decode($string, 'xml')`). Both the vulnerable method and the data handler are not used in the Kirby core. However they may be used in site or plugin code, e.g. to parse RSS feeds or other XML files. If those files are of an external origin (e.g. uploaded by a user or retrieved from an external URL), attackers may be able to include an external entity in the XML file that will then be processed in the parsing process. Kirby sites that don't use XML parsing in site or plugin code are *not* affected.
The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have removed the `LIBXML_NOENT` constant as processing of external entities is out of scope of the parsing logic. This protects all uses of the method against the described vulnerability.
Which versions are affected by CVE-2023-38490?
10 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 3.5.8.3 |
getkirby/cms Packagist | All versions | 3.5.8.3 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.3 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.3 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.2 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.2 |
4 more packages
getkirby/cms Packagist | From 3.8.0 | 3.8.4.1 |
getkirby/cms Packagist | From 3.8.0 | 3.8.4.1 |
getkirby/cms Packagist | From 3.9.0 | 3.9.6 |
getkirby/cms Packagist | From 3.9.0 | 3.9.6 |
Products include Getkirby Kirby.
How do I fix CVE-2023-38490?
Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.3, 3.6.6.3, 3.7.5.2 or 3.8.4.1.
Is CVE-2023-38490 being exploited?
There is no known exploitation of CVE-2023-38490 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-q386-w6fg-gmgp.