# CVE-2023-38490: Kirby XML External Entity (XXE) vulnerability in the XML data handler


- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Jul 2023
- **Updated:** 16 Oct 2024
- **Also known as:** GHSA-q386-w6fg-gmgp

## What is CVE-2023-38490?

CVE-2023-38490 is a medium-severity vulnerability in getkirby kirby, published on 27 Jul 2023. 

### Official description

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 only affects Kirby sites that use the `Xml` data handler (e.g. `Data::decode($string, 'xml')`) or the `Xml::parse()` method in site or plugin code. The Kirby core does not use any of the affected methods.

XML External Entities (XXE) is a little used feature in the XML markup language that allows to include data from external files in an XML structure. If the name of the external file can be controlled by an attacker, this becomes a vulnerability that can be abused for various system impacts like the disclosure of internal or confidential data that is stored on the server (arbitrary file disclosure) or to perform network requests on behalf of the server (server-side request forgery, SSRF).

Kirby's `Xml::parse()` method used PHP's `LIBXML_NOENT` constant, which enabled the processing of XML external entities during the parsing operation. The `Xml::parse()` method is used in the `Xml` data handler (e.g. `Data::decode($string, 'xml')`). Both the vulnerable method and the data handler are not used in the Kirby core. However they may be used in site or plugin code, e.g. to parse RSS feeds or other XML files. If those files are of an external origin (e.g. uploaded by a user or retrieved from an external URL), attackers may be able to include an external entity in the XML file that will then be processed in the parsing process. Kirby sites that don't use XML parsing in site or plugin code are *not* affected.

The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have removed the `LIBXML_NOENT` constant as processing of external entities is out of scope of the parsing logic. This protects all uses of the method against the described vulnerability.

Weakness: CWE-776 (Improper Restriction of Recursive Entity References in DTDs), CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2023-38490?

10 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 3.5.8.3 |
| `getkirby/cms` | Packagist | All versions | 3.5.8.3 |
| `getkirby/cms` | Packagist | From 3.6.0 | 3.6.6.3 |
| `getkirby/cms` | Packagist | From 3.6.0 | 3.6.6.3 |
| `getkirby/cms` | Packagist | From 3.7.0 | 3.7.5.2 |
| `getkirby/cms` | Packagist | From 3.7.0 | 3.7.5.2 |
| `getkirby/cms` | Packagist | From 3.8.0 | 3.8.4.1 |
| `getkirby/cms` | Packagist | From 3.8.0 | 3.8.4.1 |
| `getkirby/cms` | Packagist | From 3.9.0 | 3.9.6 |
| `getkirby/cms` | Packagist | From 3.9.0 | 3.9.6 |

Products: Getkirby Kirby.

## How do I fix CVE-2023-38490?

Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.3, 3.6.6.3, 3.7.5.2 or 3.8.4.1.

## Is CVE-2023-38490 being exploited?

There is no known exploitation of CVE-2023-38490 in the wild and no public exploit code.

Public exploit code:

- Kirby < 3.9.6 XML External Entity exploit (github_poc): https://github.com/Acceis/exploit-CVE-2023-38490

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38490 and fix it if it is affected.

What it is: CVE-2023-38490 is a medium-severity vulnerability in getkirby kirby, published on 27 Jul 2023. 
Exploitation: There is no known exploitation of CVE-2023-38490 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.3
- getkirby/cms (Packagist): affected all versions; fixed in 3.5.8.3
- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.3
- getkirby/cms (Packagist): affected from 3.6.0; fixed in 3.6.6.3
- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.2
- getkirby/cms (Packagist): affected from 3.7.0; fixed in 3.7.5.2
- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.4.1
- getkirby/cms (Packagist): affected from 3.8.0; fixed in 3.8.4.1
- getkirby/cms (Packagist): affected from 3.9.0; fixed in 3.9.6
- getkirby/cms (Packagist): affected from 3.9.0; fixed in 3.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38490/ (Markdown: https://insights.sbomify.com/CVE-2023-38490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38490
- OSV: https://osv.dev/vulnerability/CVE-2023-38490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38490/
Summaries are generated and may contain mistakes; the official description above is the record.
