CVE-2023-38491 Kirby vulnerable to Cross-site scripting (XSS) from MIME type auto-detection of uploaded files
Authenticated users can upload malicious files that execute scripts in victim browsers due to incorrect MIME type handling, potentially leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2023-38491?
CVE-2023-38491 is a medium-severity cross-site scripting vulnerability in getkirby kirby, published on 27 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to upload an arbitrary file to the content folder. Kirby sites are not affected if they don't allow file uploads for untrusted users or visitors or if the file extensions of uploaded files are limited to a fixed safe list. The attack requires user interaction by another user or visitor and cannot be automated.
An editor with write access to the Kirby Panel could upload a file with an unknown file extension like `.xyz` that contains HTML code including harmful content like `<script>` tags. The direct link to that file could be sent to other users or visitors of the site. If the victim opened that link in a browser where they are logged in to Kirby and the file had not been opened by anyone since the upload, Kirby would not be able to send the correct MIME content type, instead falling back to `text/html`. The browser would then run the script, which could for example trigger requests to Kirby's API with the permissions of the victim.
The issue was caused by the underlying `Kirby\Http\Response::file()` method, which didn't have an explicit fallback if the MIME type could not be determined from the file extension. If you use this method in site or plugin code, these uses may be affected by the same vulnerability.
The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have fixed the affected method to use a fallback MIME type of `text/plain` and set the `X-Content-Type-Options: nosniff` header if the MIME type of the file is unknown.
Weakness: CWE-79
Which versions are affected by CVE-2023-38491?
10 open source packages ship an affected version, including getkirby/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
getkirby/cms Packagist | All versions | 3.5.8.3 |
getkirby/cms Packagist | All versions | 3.5.8.3 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.3 |
getkirby/cms Packagist | From 3.6.0 | 3.6.6.3 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.2 |
getkirby/cms Packagist | From 3.7.0 | 3.7.5.2 |
4 more packages
getkirby/cms Packagist | From 3.8.0 | 3.8.4.1 |
getkirby/cms Packagist | From 3.8.0 | 3.8.4.1 |
getkirby/cms Packagist | From 3.9.0 | 3.9.6 |
getkirby/cms Packagist | From 3.9.0 | 3.9.6 |
Products include Getkirby Kirby.
How do I fix CVE-2023-38491?
Upgrade getkirby/cms to a fixed version for your release line: 3.5.8.3, 3.6.6.3, 3.7.5.2 or 3.8.4.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2023-38491 being exploited?
There is no known exploitation of CVE-2023-38491 in the wild and no public exploit code.
Other vulnerabilities in getkirby kirby
- CVE-2024-26483 Kirby vulnerable to unrestricted file upload of user avatar images
- CVE-2024-41964 Insufficient permission checks in the language settings in Kirby CMS
- CVE-2026-34587 Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering
- CVE-2021-29460 Cross-site scripting (XSS) from unsanitized uploaded SVG files
- CVE-2023-38489 Kirby vulnerable to Insufficient Session Expiration after a password change
Sources
Also known as GHSA-8fv7-wq38-f5c9.