CVE-2023-38498 Discourse vulnerable to DoS via defer queue

Medium 4.3 Published Updated

A malicious user can cause a denial of service in Discourse multisite installations by blocking the defer queue, requiring an upgrade to fix.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2023-38498?

CVE-2023-38498 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 28 Jul 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Discourse is an open source discussion platform. Prior to version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches, a malicious user can prevent the defer queue from proceeding promptly on sites hosted in the same multisite installation. The issue is patched in version 3.0.6 of the `stable` branch and version 3.1.0.beta7 of the `beta` and `tests-passed` branches. There are no known workarounds for this vulnerability. Users of multisite configurations should upgrade.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2023-38498?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions3.0.6

Products include Discourse Discourse.

How do I fix CVE-2023-38498?

Upgrade discourse to 3.0.6 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2023-38498 being exploited?

There is no known exploitation of CVE-2023-38498 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2023-38498, GHSA-wv29-rm3f-4g2j.

Is CVE-2023-38498 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free