# CVE-2023-38499: typo3/cms-core Information Disclosure due to Out-of-scope Site Resolution

> Attackers can access internal site content by manipulating query parameters in multi-site TYPO3 installations, exposing sensitive data.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 15 Oct 2024
- **Also known as:** BIT-typo3-2023-38499, GHSA-jq6g-4v5m-wm9r

## What is CVE-2023-38499?

CVE-2023-38499 is a low-severity vulnerability in Typo3 Typo3, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TYPO3 is an open source PHP based web content management system. Starting in version 9.4.0 and prior to versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30, and 12.4.4, in multi-site scenarios, enumerating the HTTP query parameters `id` and `L` allowed out-of-scope access to rendered content in the website frontend. For instance, this allowed visitors to access content of an internal site by adding handcrafted query parameters to the URL of a site that was publicly available. TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30, 12.4.4 fix the problem.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2023-38499?

9 open source packages ship an affected version, including typo3/cms-core and typo3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.39 |
| `typo3/cms-core` | Packagist | From 10.0.0 | 10.4.39 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.30 |
| `typo3/cms-core` | Packagist | From 11.0.0 | 11.5.30 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.4 |
| `typo3/cms-core` | Packagist | From 12.0.0 | 12.4.4 |
| `typo3/cms-core` | Packagist | From 9.4.0 | 9.5.42 |
| `typo3/cms-core` | Packagist | From 9.4.0 | 9.5.42 |
| `typo3` | Bitnami | From 9.4.0 | 9.5.42, 10.4.39, 11.5.30, 12.4.4 |

Products: Typo3 Typo3.

## How do I fix CVE-2023-38499?

Upgrade typo3/cms-core to a fixed version for your release line: 10.4.39, 11.5.30, 12.4.4 or 9.5.42.

## Is CVE-2023-38499 being exploited?

There is no known exploitation of CVE-2023-38499 in the wild and no public exploit code.

## Other vulnerabilities in Typo3 Typo3

- [CVE-2009-0258](https://insights.sbomify.com/CVE-2009-0258/): Indexed Search Engine for TYPO3 Command Execution via Metacharacter Injection (critical 10.0)
- [CVE-2011-3583](https://insights.sbomify.com/CVE-2011-3583/): Typo3 SQL injection due to faulty prepared statements (critical 9.8)
- [CVE-2011-4628](https://insights.sbomify.com/CVE-2011-4628/): Typo3 Authentication Bypass (critical 9.8)
- [CVE-2023-24814](https://insights.sbomify.com/CVE-2023-24814/): Persisted Cross-Site Scripting in Frontend Rendering in typo3 (high 8.8)
- [CVE-2021-41113](https://insights.sbomify.com/CVE-2021-41113/): Cross-Site-Request-Forgery in Backend URI Handling in Typo3 (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38499 and fix it if it is affected.

What it is: CVE-2023-38499 is a low-severity vulnerability in Typo3 Typo3, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2023-38499 in the wild and no public exploit code.

Affected packages and fixed versions:
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.39
- typo3/cms-core (Packagist): affected from 10.0.0; fixed in 10.4.39
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.30
- typo3/cms-core (Packagist): affected from 11.0.0; fixed in 11.5.30
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.4
- typo3/cms-core (Packagist): affected from 12.0.0; fixed in 12.4.4
- typo3/cms-core (Packagist): affected from 9.4.0; fixed in 9.5.42
- typo3/cms-core (Packagist): affected from 9.4.0; fixed in 9.5.42
- typo3 (Bitnami): affected from 9.4.0; fixed in 9.5.42, 10.4.39, 11.5.30, 12.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38499/ (Markdown: https://insights.sbomify.com/CVE-2023-38499/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38499
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38499
- OSV: https://osv.dev/vulnerability/CVE-2023-38499

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38499/
Summaries are generated and may contain mistakes; the official description above is the record.
