# CVE-2023-38501: copyparty vulnerable to reflected cross-site scripting via k304 parameter

> Attackers can execute scripts in victim browsers via malicious links, allowing file manipulation or account takeover on copyparty servers.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2023
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-f54q-j679-p9hh, PYSEC-2023-132

## What is CVE-2023-38501?

CVE-2023-38501 is a medium-severity cross-site scripting vulnerability in 9001 copyparty, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

copyparty is file server software. Prior to version 1.8.7, the application contains a reflected cross-site scripting via URL-parameter `?k304=...` and `?setck=...`. The worst-case outcome of this is being able to move or delete existing files on the server, or upload new files, using the account of the person who clicks the malicious link. It is recommended to change the passwords of one's copyparty accounts, unless one have inspected one's logs and found no trace of attacks. Version 1.8.7 contains a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2023-38501?

3 open source packages ship an affected version, including copyparty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `copyparty` | PyPI | All versions | 1.8.7 |
| `copyparty` | PyPI | All versions | 1.8.7 |
| `copyparty` | PyPI | All versions | 1.8.7 |

Products: 9001 Copyparty.

## How do I fix CVE-2023-38501?

Upgrade copyparty to 1.8.7 or later.

## Is CVE-2023-38501 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38501 exists.

Public exploit code:

- copyparty v1.8.6 - Reflected Cross Site Scripting (XSS) (exploitdb)
- CopyParty v1.8.6 - Cross Site Scripting (nuclei): http/cves/2023/CVE-2023-38501.yaml

## Other vulnerabilities in 9001 copyparty

- [CVE-2023-41471](https://insights.sbomify.com/CVE-2023-41471/): Cross-site scripting in n/a (high 7.8)
- [CVE-2025-54796](https://insights.sbomify.com/CVE-2025-54796/): Copyparty is vulnerable to Regex Denial of Service (ReDoS) attacks through "Recent Uploads" page (high 7.5)
- [CVE-2023-37474](https://insights.sbomify.com/CVE-2023-37474/): Path traversal in copyparty (high 7.5)
- [CVE-2025-54589](https://insights.sbomify.com/CVE-2025-54589/): copyparty Reflected XSS via Filter Parameter (medium 6.3)
- [CVE-2026-27948](https://insights.sbomify.com/CVE-2026-27948/): Copyparty vulnerable to eflected cross-site scripting via setck parameter (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2023-38501 and fix it if it is affected.

What it is: CVE-2023-38501 is a medium-severity cross-site scripting vulnerability in 9001 copyparty, published on 25 Jul 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2023-38501 exists.

Affected packages and fixed versions:
- copyparty (PyPI): affected all versions; fixed in 1.8.7
- copyparty (PyPI): affected all versions; fixed in 1.8.7
- copyparty (PyPI): affected all versions; fixed in 1.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2023-38501/ (Markdown: https://insights.sbomify.com/CVE-2023-38501/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2023-38501
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2023-38501
- OSV: https://osv.dev/vulnerability/CVE-2023-38501

---
From sbomify Insights: https://insights.sbomify.com/CVE-2023-38501/
Summaries are generated and may contain mistakes; the official description above is the record.
