{"answers":{"affected":"2 open source packages ship an affected version, including sails. It affects 1 product.","exploited":"There is no known exploitation of CVE-2023-38504 in the wild and no public exploit code.","fix":"Upgrade sails to 1.5.7 or later.","what":"CVE-2023-38504 is a high-severity denial of service vulnerability in balderdashy sails, published on 27 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2023-38504 and fix it if it is affected.\n\nWhat it is: CVE-2023-38504 is a high-severity denial of service vulnerability in balderdashy sails, published on 27 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2023-38504 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sails (npm): affected all versions; fixed in 1.5.7\n- sails (npm): affected all versions; fixed in 1.5.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2023-38504/ (Markdown: https://insights.sbomify.com/CVE-2023-38504/index.md)","id":"CVE-2023-38504","markdown":"https://insights.sbomify.com/CVE-2023-38504/index.md","name":"CVE-2023-38504","record":{"aliases":["GHSA-gpw9-fwm8-7rx7"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js MVC framework","requires_auth":"none","summary":"An attacker can crash the Node.js process by sending a malicious virtual request in Sails apps with sockets enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sails","vendor":"sailsjs"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Sails DoS vulnerability for apps with sockets enabled","id":"CVE-2023-38504","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2023"},"n_packages":2,"n_references":4,"next":{"headline":"DietPi-Dashboard Insufficient TLS Handshake Pool","id":"CVE-2023-38505"},"packages":[{"ecosystem":"npm","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"sails","purl":null,"source":"GHSA-gpw9-fwm8-7rx7"},{"ecosystem":"npm","fixed":["1.5.7"],"introduced":["0"],"last_affected":[],"package":"sails","purl":"pkg:npm/sails","source":"GHSA-gpw9-fwm8-7rx7"}],"prev":{"headline":"Directus has Incorrect Permission Checking for GraphQL Subscriptions","id":"CVE-2023-38503"},"products":["sails"],"published":"2023-07-27","related":[{"cvss_score":9.8,"headline":"Prototype Pollution in Sails.js","id":"CVE-2021-44908","kev_date_added":null,"published":"2022-03-17"},{"cvss_score":7.5,"headline":"Improper Input Validation in sails-hook-sockets","id":"CVE-2018-21036","kev_date_added":null,"published":"2020-07-21"},{"cvss_score":4.4,"headline":"Sails before 0.12.7 vulnerable to Broken CORS","id":"CVE-2016-10549","kev_date_added":null,"published":"2018-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-10-03","vendors":["balderdashy"]},"summary":"An attacker can crash the Node.js process by sending a malicious virtual request in Sails apps with sockets enabled.","url":"https://insights.sbomify.com/CVE-2023-38504/"}